Skip to content

← Actionable
High, CVSS 7.8

Faker: helpers.fake exploitable into arbritary code execution

CVE-2026-73231GHSA-qxc2-j82w-r537

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@faker-js/faker 10.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-73231: 0.21% estimated exploitation activity in the next 30 days; percentile 11.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary faker.helpers.fake can be tricked into arbritary code execution. Details fakeEval.resolveProperty resolves properties on functions itself instead of resolving the nested function first. This can be addressed by recursively calling resolveProperty instead of accessing the property after one iteration. PoC Go to https://fakerjs.dev/ Open Browser console and run Impact The Fake method claims: It is also NOT possible to use any non-faker methods or plain javascript in such patterns. Which is objectively false, since any global gets fully accessible in the fake string.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qxc2-j82w-r537

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-73231

Advisory: Faker: helpers.fake exploitable into arbritary code execution
IDs: CVE-2026-73231, GHSA-qxc2-j82w-r537
Record: https://patchnext.com/advisories/cve-2026-73231 (revision 1, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @faker-js/faker 10.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @faker-js/faker: affected <= 10.4.0; fixed in 10.5.0

## Suggested inspection (read-only)
- `npm ls @faker-js/faker --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @faker-js/faker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qxc2-j82w-r537 (GitHub-reviewed advisory GHSA-qxc2-j82w-r537 lists affected ranges: npm @faker-js/faker >=0 <=10.4.0)

Commands are suggestions: review each one before running it.

Loading voting…