Claude Code Templates: Unauthenticated OS command injection (RCE) in Claude Code Studio server (--studio)
CVE-2026-73222GHSA-79wm-x847-7cvg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (claude-code-templates 1.29.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 1.29.2
- Fixed in
- 1.29.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-79wm-x847-7cvg lists affected ranges: npm claude-code-templates >=0 <=1.29.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-73222: 0.32% estimated exploitation activity in the next 30 days; percentile 24.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary npx claude-code-templates --studio launches "Claude Code Studio", an Express HTTP server (cli-tool/src/sandbox-server.js, default port 3444) that binds to all interfaces (0.0.0.0), sets Access-Control-Allow-Origin: , and requires no authentication. Two POST endpoints pass attacker-controlled request-body fields into childprocess.spawn(..., { shell: true }). Because shell: true makes Node join the argv array into a single sh -c string, the fields are parsed by the shell and metacharacters execute. Any unauthenticated attacker who can reach the port — a malicious web page the developer visits, or anyone on the same LAN — can execute arbitrary OS commands on the developer's machine. Details In cli-tool/src/sandbox-server.js: - app.listen(PORT, ...) is called with no host argument, so the server listens on 0.0.0.0 / :: (reachable from the LAN, not just localhost). - The CORS middleware sends Access-Control-Allow-Origin: and answers the preflight OPTIONS for any origin, so a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-79wm-x847-7cvg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-73222 Advisory: Claude Code Templates: Unauthenticated OS command injection (RCE) in Claude Code Studio server (--studio) IDs: CVE-2026-73222, GHSA-79wm-x847-7cvg Record: https://patchnext.com/advisories/cve-2026-73222 (revision 1, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: claude-code-templates 1.29.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm claude-code-templates: affected <= 1.29.2; fixed in 1.29.4 ## Suggested inspection (read-only) - `npm ls claude-code-templates --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on claude-code-templates. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-79wm-x847-7cvg (GitHub-reviewed advisory GHSA-79wm-x847-7cvg lists affected ranges: npm claude-code-templates >=0 <=1.29.2) Commands are suggestions: review each one before running it.
Loading voting…