Microsoft.OpenApi.YamlReader vulnerable to denial of service via YAML alias expansion
CVE-2026-72923GHSA-7pxr-59rr-hqj2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (microsoft.openapi.yamlreader 3.10.0, 2.12.0; microsoft.openapi.readers 1.6.30), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet microsoft.openapi.yamlreader
- Affected
- >= 3.0.0, < 3.10.0>= 2.0.0-preview.11, < 2.12.0
- Fixed in
- 3.10.0, 2.12.0
NuGet microsoft.openapi.readers
- Affected
- < 1.6.30
- Fixed in
- 1.6.30
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7pxr-59rr-hqj2 lists affected ranges: NuGet microsoft.openapi.yamlreader >=3.0.0 =2.0.0-preview.11 =0 <1.6.30 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7pxr-59rr-hqj2 lists affected ranges: NuGet microsoft.openapi.yamlreader >=3.0.0 =2.0.0-preview.11 =0 <1.6.30
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-72923: 1.85% estimated exploitation activity in the next 30 days; percentile 79.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A small YAML OpenAPI document containing nested anchors and aliases can cause uncontrolled resource consumption in Microsoft.OpenApi.YamlReader and Microsoft.OpenApi.Readers. The issue affects OpenAPI document parsing through the public YAML reader APIs and can cause the parsing process to allocate excessive memory and terminate through out-of-memory conditions. Affected versions Microsoft.OpenApi.YamlReader = 2.0.0-preview.11, < 2.12.0 = 3.0.0, < 3.10.0 Microsoft.OpenApi.Readers < 1.6.30 Patches For the 1.X major version, versions 1.6.30 and above are patched. For the 2.X major version, versions 2.12.0 and above are patched. For the 3.X major version, versions 3.10.0 and above are patched. Impact Applications, CLIs, developer tools, or services that parse untrusted YAML OpenAPI documents in-process may be terminated by a crafted YAML document containing nested anchors and aliases. The impact is availability/process termination only. This report does not claim remote code…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7pxr-59rr-hqj2
- Revision 1 · created ·
Published from osv record GHSA-7pxr-59rr-hqj2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-72923 Advisory: Microsoft.OpenApi.YamlReader vulnerable to denial of service via YAML alias expansion IDs: CVE-2026-72923, GHSA-7pxr-59rr-hqj2 Record: https://patchnext.com/advisories/cve-2026-72923 (revision 2, source checked 26 Oct 2026, 17:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: microsoft.openapi.yamlreader 3.10.0, 2.12.0; microsoft.openapi.readers 1.6.30. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet microsoft.openapi.yamlreader: affected >= 3.0.0, < 3.10.0; >= 2.0.0-preview.11, < 2.12.0; fixed in 3.10.0, 2.12.0 - NuGet microsoft.openapi.readers: affected < 1.6.30; fixed in 1.6.30 ## Suggested inspection (read-only) - NuGet microsoft.openapi.yamlreader: check the installed version with your package manager. - NuGet microsoft.openapi.readers: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on microsoft.openapi.yamlreader, microsoft.openapi.readers. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7pxr-59rr-hqj2 (OSV record GHSA-7pxr-59rr-hqj2 lists affected ranges: NuGet microsoft.openapi.yamlreader >=3.0.0 =2.0.0-preview.11 =0 <1.6.30 (fixed)) - Verified: https://github.com/advisories/GHSA-7pxr-59rr-hqj2 (GitHub-reviewed advisory GHSA-7pxr-59rr-hqj2 lists affected ranges: NuGet microsoft.openapi.yamlreader >=3.0.0 =2.0.0-preview.11 =0 <1.6.30) Commands are suggestions: review each one before running it.
Loading voting…