Grav: Stored XSS via quoted-attribute bypass in detectXss
CVE-2026-72832GHSA-269c-h76q-8cxw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 2.0.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getgrav/grav
- Affected
- >= 1.5.2, <= 2.0.12
- Fixed in
- 2.0.13
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-269c-h76q-8cxw lists affected ranges: Packagist getgrav/grav >=1.5.2 <2.0.13 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-269c-h76q-8cxw lists affected ranges: Packagist getgrav/grav >=1.5.2 <=2.0.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-72832: 0.31% estimated exploitation activity in the next 30 days; percentile 24.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A page editor without admin.super can place an event handler after a inside a quoted attribute. Grav accepts and stores the page, then executes the handler in the application origin when a visitor opens it. Details Security::detectXss() (system/src/Grav/Common/Security.php:253) anchors the onevents scan at < and uses [^]?, which cannot cross the first literal . When that character is inside a quoted value, the browser keeps the tag open and parses the later onerror attribute, so the detector and browser disagree. AdminController::savePage() relies on this detector when saving content from page editors outside the admin.super whitelist. PoC I reproduced this with getgrav/grav 2.0.11 (ad9709f865b09b68798fb1ac375b484a8cc1d892), Admin 1.10.52, and Quark 2 1.1.4. 1. Sign in as a user with admin.login and admin.pages, but without admin.super. 2. Create or edit /xsstest and save this page body: 3. Open /xsstest in a private browser window. The save succeeds and the visitor sees an…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-269c-h76q-8cxw
- Revision 1 · created ·
Published from osv record GHSA-269c-h76q-8cxw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-72832 Advisory: Grav: Stored XSS via quoted-attribute bypass in detectXss IDs: CVE-2026-72832, GHSA-269c-h76q-8cxw Record: https://patchnext.com/advisories/cve-2026-72832 (revision 2, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 2.0.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getgrav/grav: affected >= 1.5.2, <= 2.0.12; fixed in 2.0.13 ## Suggested inspection (read-only) - Packagist getgrav/grav: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getgrav/grav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-269c-h76q-8cxw (OSV record GHSA-269c-h76q-8cxw lists affected ranges: Packagist getgrav/grav >=1.5.2 <2.0.13 (fixed)) - Verified: https://github.com/advisories/GHSA-269c-h76q-8cxw (GitHub-reviewed advisory GHSA-269c-h76q-8cxw lists affected ranges: Packagist getgrav/grav >=1.5.2 <=2.0.12) Commands are suggestions: review each one before running it.
Loading voting…