Skip to content

← Actionable
Medium, CVSS 5.1amended

Craft CMS: Stored XSS in the control panel via unescaped draft name

CVE-2026-72787GHSA-2rp4-x2j7-qmcc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.10.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 5.0.0-RC1, < 5.10.8
    Fixed in
    5.10.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-72787: 0.26% estimated exploitation activity in the next 30 days; percentile 17.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The control-panel helper that renders element chip/card labels writes an element's draftName into the page without HTML-encoding it, while the surrounding path segments are encoded. A low-privilege control-panel user who can create a draft of an element (for example, an entry) controls the draft name, so they can store an XSS payload that executes in the browser of any other control-panel user who is shown that element’s chip or card (element indexes with drafts visible, relation and element-selection fields that reference the element, and the drafts list). This allows a low-privilege author to run JavaScript in an administrator’s authenticated session and take over the control panel. It is the same output-encoding class as the recently fixed GHSA-xrqc-p465-2xvg (Structure entry title) and GHSA-3x4w-mxpf-fhqq (revision context menu), which encoded other user-controlled titles but not the draft name. Prerequisites - A control-panel account with permission to edit entries in at least…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2rp4-x2j7-qmcc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2rp4-x2j7-qmcc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-72787

Advisory: Craft CMS: Stored XSS in the control panel via unescaped draft name
IDs: CVE-2026-72787, GHSA-2rp4-x2j7-qmcc
Record: https://patchnext.com/advisories/cve-2026-72787 (revision 3, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.10.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 5.0.0-RC1, < 5.10.8; fixed in 5.10.8

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2rp4-x2j7-qmcc (OSV record GHSA-2rp4-x2j7-qmcc lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 <5.10.8 (fixed))
- Verified: https://github.com/advisories/GHSA-2rp4-x2j7-qmcc (GitHub-reviewed advisory GHSA-2rp4-x2j7-qmcc lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 <5.10.8)

Commands are suggestions: review each one before running it.

Loading voting…