Craft CMS: Arbitrary user password reset leading to administrator account takeover
CVE-2026-72786GHSA-p8x7-9vfw-p7vc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.10.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/cms
- Affected
- >= 5.0.0-RC1, < 5.10.8
- Fixed in
- 5.10.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p8x7-9vfw-p7vc lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 <5.10.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p8x7-9vfw-p7vc lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 <5.10.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-72786: 0.46% estimated exploitation activity in the next 30 days; percentile 40.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
- CVE-2026-79989: 0.43% estimated exploitation activity in the next 30 days; percentile 37.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The vulnerability allows any authenticated user to change their own password without providing the current password or having an active elevated session. It also allows the attacker to change other users’ passwords if the attacker’s account has edit users permission (which doesn’t allow changing others’ passwords) and lacks Administrate users permission (which is required to change others’ passwords). The vulnerability exists in the elements/save action when saving a User element. The UserPasswordValidator applies only a safe validator to the newPassword field without an on scenario restriction. This makes newPassword mass-assignable during the generic element save flow, completely bypassing the dedicated users/set-password action that enforces elevated session verification. An attacker with any authenticated session (whether it’s hijacked or a normal / low-privileged user) can change their own password, and potentially take over administrator accounts. Required Permissions - Access…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p8x7-9vfw-p7vc
- Revision 1 · created ·
Published from osv record GHSA-p8x7-9vfw-p7vc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-72786 Advisory: Craft CMS: Arbitrary user password reset leading to administrator account takeover IDs: CVE-2026-72786, GHSA-p8x7-9vfw-p7vc Record: https://patchnext.com/advisories/cve-2026-72786 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.10.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/cms: affected >= 5.0.0-RC1, < 5.10.8; fixed in 5.10.8 ## Suggested inspection (read-only) - Packagist craftcms/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p8x7-9vfw-p7vc (OSV record GHSA-p8x7-9vfw-p7vc lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 <5.10.8 (fixed)) - Verified: https://github.com/advisories/GHSA-p8x7-9vfw-p7vc (GitHub-reviewed advisory GHSA-p8x7-9vfw-p7vc lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 <5.10.8) Commands are suggestions: review each one before running it.
Loading voting…