Skip to content

← Actionable
High, CVSS 8.7amended

Craft CMS: Authenticated RCE through Twig sandbox escape

CVE-2026-72781GHSA-f5wm-88jv-g5hx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.10.7, 4.18.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 5.0.0-RC1, < 5.10.7>= 4.0.0-RC1, < 4.18.3
    Fixed in
    4.18.3, 5.10.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-72781: 0.79% estimated exploitation activity in the next 30 days; percentile 56.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Twig sandbox mechanism in Craft CMS is configured to allow dangerous functionality from the Yii framework, leading to authenticated RCE in a manner similar to previously disclosed vulnerabilities. The Twig sandbox in Craft CMS works by implementing Twig's SecurityPolicyInterface. The resulting SecurityPolicy class implements the checkMethodAllowed and checkPropertyAllowed methods of the interface. The implementations compare whether the called method or property is in a configured allowlist or is marked with the AllowedInSandbox attribute. Additionally, SecurityPolicy allows the allowlisting of whole classes, which is shorthand for allowing all methods and properties of that class to be called. Both the allowlists for tags, filters, variables, methods, properties, and classes, as well as the AllowedInSandbox attribute mechanism, are preconfigured by Craft CMS to allow user-defined templates to use core functionality unimpeded. Additionally, Craft CMS project developers can add…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-f5wm-88jv-g5hx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-f5wm-88jv-g5hx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-72781

Advisory: Craft CMS: Authenticated RCE through Twig sandbox escape
IDs: CVE-2026-72781, GHSA-f5wm-88jv-g5hx
Record: https://patchnext.com/advisories/cve-2026-72781 (revision 3, source checked 26 Oct 2026, 14:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.10.7, 4.18.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 5.0.0-RC1, < 5.10.7; >= 4.0.0-RC1, < 4.18.3; fixed in 4.18.3, 5.10.7

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f5wm-88jv-g5hx (OSV record GHSA-f5wm-88jv-g5hx lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 =4.0.0-RC1 <4.18.3 (fixed))
- Verified: https://github.com/advisories/GHSA-f5wm-88jv-g5hx (GitHub-reviewed advisory GHSA-f5wm-88jv-g5hx lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 =4.0.0-RC1 <4.18.3)

Commands are suggestions: review each one before running it.

Loading voting…