Skip to content

← Actionable
Medium, CVSS 5.8amended

n8n: PostgresTrigger Node SQL Injection Allows Authenticated Users to Execute Arbitrary SQL on Connected PostgreSQL Instances

CVE-2026-72775GHSA-jqwr-vx3p-r266

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.32.1, 2.31.5, 1.123.67), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    < 1.123.67>= 2.32.0, < 2.32.1>= 2.0.0-rc.0, < 2.31.5
    Fixed in
    2.31.5, 2.32.1, 1.123.67

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-72775: 0.47% estimated exploitation activity in the next 30 days; percentile 40.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Postgres Trigger node interpolated user-supplied identifier parameters (channel, function, and trigger names) into SQL statements without proper escaping, so an authenticated user could inject arbitrary SQL executed against the connected PostgreSQL database with the configured credential's privileges. Successful exploitation allows full read and write access to the connected PostgreSQL database. Patches The issue has been fixed in n8n versions 1.123.67, 2.31.5 and 2.32.1. Users should upgrade to these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict n8n instance access to fully trusted users only. - Disable the PostgresTrigger node by adding n8n-nodes-base.postgresTrigger to the NODESEXCLUDE environment variable. - Ensure PostgreSQL credentials used with n8n are configured with the minimum required privileges and do not use SUPERUSER roles.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jqwr-vx3p-r266

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-jqwr-vx3p-r266

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-72775

Advisory: n8n: PostgresTrigger Node SQL Injection Allows Authenticated Users to Execute Arbitrary SQL on Connected PostgreSQL Instances
IDs: CVE-2026-72775, GHSA-jqwr-vx3p-r266
Record: https://patchnext.com/advisories/cve-2026-72775 (revision 3, source checked 26 Oct 2026, 12:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.32.1, 2.31.5, 1.123.67. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected < 1.123.67; >= 2.32.0, < 2.32.1; >= 2.0.0-rc.0, < 2.31.5; fixed in 2.31.5, 2.32.1, 1.123.67

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jqwr-vx3p-r266 (OSV record GHSA-jqwr-vx3p-r266 lists affected ranges: npm n8n >=0 =2.32.0 =2.0.0-rc.0 <2.31.5 (fixed))
- Verified: https://github.com/advisories/GHSA-jqwr-vx3p-r266 (GitHub-reviewed advisory GHSA-jqwr-vx3p-r266 lists affected ranges: npm n8n >=0 =2.32.0 =2.0.0-rc.0 <2.31.5)

Commands are suggestions: review each one before running it.

Loading voting…