Skip to content

← Actionable
Medium, CVSS 4.9amended

n8n: Path-Confinement Bypass in computer-use search_files Allows Reading Files Outside the Base Directory

CVE-2026-72773GHSA-pf2q-pxhf-hgmw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.32.1, 2.31.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    >= 2.32.0, < 2.32.1< 2.31.5
    Fixed in
    2.31.5, 2.32.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2026-72773: 0.57% estimated exploitation activity in the next 30 days; percentile 47.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The component @n8n/computer-use file-search tool confined searches to a configured base directory. A crafted search pattern could bypass the confinement check and expand to locations outside that directory, causing the tool to return the names and contents of files anywhere the daemon's OS user could read. Any deployment where an actor could influence the tool's search input was affected; the result was disclosure of arbitrary local files outside the intended sandbox. Patches The issue has been fixed in n8n versions 2.31.5 and 2.32.1. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict n8n instance access to fully trusted users only. - Disable or remove AI agent workflows that use the computer-use package until the instance is patched. - Ensure the n8n process runs under a dedicated low-privilege user account to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-pf2q-pxhf-hgmw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-pf2q-pxhf-hgmw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-72773

Advisory: n8n: Path-Confinement Bypass in computer-use search_files Allows Reading Files Outside the Base Directory
IDs: CVE-2026-72773, GHSA-pf2q-pxhf-hgmw
Record: https://patchnext.com/advisories/cve-2026-72773 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.32.1, 2.31.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected >= 2.32.0, < 2.32.1; < 2.31.5; fixed in 2.31.5, 2.32.1

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pf2q-pxhf-hgmw (OSV record GHSA-pf2q-pxhf-hgmw lists affected ranges: npm n8n >=2.32.0 =0 <2.31.5 (fixed))
- Verified: https://github.com/advisories/GHSA-pf2q-pxhf-hgmw (GitHub-reviewed advisory GHSA-pf2q-pxhf-hgmw lists affected ranges: npm n8n >=2.32.0 =0 <2.31.5)

Commands are suggestions: review each one before running it.

Loading voting…