Skip to content

← Actionable
High, CVSS 8.7amended

n8n: Authenticated code execution in the n8n Git node

CVE-2026-72767GHSA-rcv6-pvrj-4xcg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.32.1, 2.31.5, 1.123.67), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    < 1.123.67>= 2.32.0, < 2.32.1>= 2.0.0-rc.0, < 2.31.5
    Fixed in
    2.31.5, 2.32.1, 1.123.67

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-72767: 0.88% estimated exploitation activity in the next 30 days; percentile 59.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Authenticated n8n users with rights to create and execute workflows could achieve code execution on the n8n host. Using the Git node, under the default git security settings, by staging a crafted local repository, an attacker could cause git to run hooks, executing arbitrary commands as the n8n process user. Both self-hosted and cloud instances are affected where authenticated users can create and execute workflows using the Git node. Patches The issue has been fixed in n8n versions 1.123.67, 2.31.5, and 2.32.1. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict n8n instance access to fully trusted users only. - Disable the Git node by adding n8n-nodes-base.git to the NODESEXCLUDE environment variable. - Restrict network egress from the n8n instance to limit the impact of arbitrary code execution. These…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rcv6-pvrj-4xcg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-rcv6-pvrj-4xcg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-72767

Advisory: n8n: Authenticated code execution in the n8n Git node
IDs: CVE-2026-72767, GHSA-rcv6-pvrj-4xcg
Record: https://patchnext.com/advisories/cve-2026-72767 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.32.1, 2.31.5, 1.123.67. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected < 1.123.67; >= 2.32.0, < 2.32.1; >= 2.0.0-rc.0, < 2.31.5; fixed in 2.31.5, 2.32.1, 1.123.67

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rcv6-pvrj-4xcg (OSV record GHSA-rcv6-pvrj-4xcg lists affected ranges: npm n8n >=0 =2.32.0 =2.0.0-rc.0 <2.31.5 (fixed))
- Verified: https://github.com/advisories/GHSA-rcv6-pvrj-4xcg (GitHub-reviewed advisory GHSA-rcv6-pvrj-4xcg lists affected ranges: npm n8n >=0 =2.32.0 =2.0.0-rc.0 <2.31.5)

Commands are suggestions: review each one before running it.

Loading voting…