Skip to content

← Actionable
Medium, CVSS 5.8amended

n8n: Cross-Tenant Module-Cache Poisoning in the JS Task Runner

CVE-2026-72764GHSA-9cmh-xcqm-5hqr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.32.1, 2.31.5, 1.123.67), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    < 1.123.67>= 2.32.0, < 2.32.1>= 2.0.0-rc.0, < 2.31.5
    Fixed in
    2.31.5, 2.32.1, 1.123.67

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-72764: 0.81% estimated exploitation activity in the next 30 days; percentile 57.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact n8n's JavaScript task runner shared one module cache across all users' Code-node executions, so a user able to run a Code node could poison a cached module and alter other users' Code-node executions on the same runner, affecting their confidentiality, integrity, or availability. This is a cross-user isolation break within a single n8n instance. It does not constitute a sandbox escape or remote code execution. All multi-user n8n instances running the JS task runner with built-in or external modules enabled are affected. Patches The issue has been fixed in n8n versions 1.123.67, 2.31.5, and 2.32.1. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict n8n instance access to fully trusted users only. - Disable built-in and external module access in Code nodes by unsetting NODEFUNCTIONALLOWBUILTIN and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9cmh-xcqm-5hqr

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9cmh-xcqm-5hqr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-72764

Advisory: n8n: Cross-Tenant Module-Cache Poisoning in the JS Task Runner
IDs: CVE-2026-72764, GHSA-9cmh-xcqm-5hqr
Record: https://patchnext.com/advisories/cve-2026-72764 (revision 3, source checked 26 Oct 2026, 12:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.32.1, 2.31.5, 1.123.67. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected < 1.123.67; >= 2.32.0, < 2.32.1; >= 2.0.0-rc.0, < 2.31.5; fixed in 2.31.5, 2.32.1, 1.123.67

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9cmh-xcqm-5hqr (OSV record GHSA-9cmh-xcqm-5hqr lists affected ranges: npm n8n >=0 =2.32.0 =2.0.0-rc.0 <2.31.5 (fixed))
- Verified: https://github.com/advisories/GHSA-9cmh-xcqm-5hqr (GitHub-reviewed advisory GHSA-9cmh-xcqm-5hqr lists affected ranges: npm n8n >=0 =2.32.0 =2.0.0-rc.0 <2.31.5)

Commands are suggestions: review each one before running it.

Loading voting…