Orval: Import-time RCE via query-parameter default -> zod module-level template literal
CVE-2026-72716GHSA-p4cg-3328-rvfg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (orval 8.21.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm orval
- Affected
- < 8.21.0
- Fixed in
- 8.21.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p4cg-3328-rvfg lists affected ranges: npm orval >=0 <8.21.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p4cg-3328-rvfg lists affected ranges: npm orval >=0 <8.21.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-72716: 0.65% estimated exploitation activity in the next 30 days; percentile 51.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Orval's zod schema generation emits the query-parameter default value as a module-level template literal (export const …Default = <default;) without escaping ${ or the backtick. A default of the form v${<code}w injects a live JavaScript expression evaluated when the generated zod schema module is imported, executing attacker-controlled code at import — no request or function call needed. Verified on Orval 8.19.0; survives default OpenAPI validation. Details Malicious input: a query parameter with a default of v${<attacker JS}w. ${...} permits any JS expression. Note: this is one of several default-bearing positions that reach the same unescaped zod template-literal sink; a single fix (escape default values) closes all of them, and a CNA may choose to consolidate the related reports. PoC reproduce.sh (+ makespec.py) attached: generates the zod schema with default validation, bundles it, imports it, and shows a marker written at import. Verified on 8.19.0. Impact Code execution…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-p4cg-3328-rvfg
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-p4cg-3328-rvfg
- Revision 1 · created ·
Published from ghsa record GHSA-p4cg-3328-rvfg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-72716 Advisory: Orval: Import-time RCE via query-parameter default -> zod module-level template literal IDs: CVE-2026-72716, GHSA-p4cg-3328-rvfg Record: https://patchnext.com/advisories/cve-2026-72716 (revision 4, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: orval 8.21.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm orval: affected < 8.21.0; fixed in 8.21.0 ## Suggested inspection (read-only) - `npm ls orval --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on orval. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p4cg-3328-rvfg (GitHub-reviewed advisory GHSA-p4cg-3328-rvfg lists affected ranges: npm orval >=0 <8.21.0) - Verified: https://osv.dev/vulnerability/GHSA-p4cg-3328-rvfg (OSV record GHSA-p4cg-3328-rvfg lists affected ranges: npm orval >=0 <8.21.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…