Grav: Non constant time nonce comparison in Utils::verifyNonce() used for CSRF protection
CVE-2026-72701GHSA-38p6-h87p-r4cg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 2.0.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getgrav/grav
- Affected
- < 2.0.16
- Fixed in
- 2.0.16
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-38p6-h87p-r4cg lists affected ranges: Packagist getgrav/grav >=0 <2.0.16 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-38p6-h87p-r4cg lists affected ranges: Packagist getgrav/grav >=0 <=2.0.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-72701: 0.22% estimated exploitation activity in the next 30 days; percentile 12.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary `Grav\Common\Utils::verifyNonce()`, the core function Grav and its plugins use to validate CSRF nonces, compares the submitted nonce to the expected value with PHP's `===` operator instead of `hash_equals()`. `===` on strings short circuits at the first differing byte, so the comparison time leaks how many leading bytes of a guess are correct. This is CWE-208, Observable Timing Discrepancy. The codebase already knows to avoid this pattern. `hash_equals()` is used for the equivalent purpose in four other places I found: `system/src/Grav/Common/Session.php`, `system/src/Grav/Framework/Cache/Adapter/FileCache.php`, `system/src/Grav/Common/Scheduler/Scheduler.php` (the webhook token check), and `system/src/Grav/Common/Scheduler/JobQueue.php`. `Utils::verifyNonce()` is the one place I found that still uses a plain equality check for a secret comparison.
Affected product and version Product: Grav CMS, getgrav/grav Confirmed present in: 2.0.15, commit…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from osv record GHSA-38p6-h87p-r4cg
- Revision 3 · amended ·
Amended from ghsa record GHSA-38p6-h87p-r4cg
- Revision 2 · amended ·
Amended from ghsa record GHSA-38p6-h87p-r4cg
- Revision 1 · created ·
Published from osv record GHSA-38p6-h87p-r4cg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-72701 Advisory: Grav: Non constant time nonce comparison in Utils::verifyNonce() used for CSRF protection IDs: CVE-2026-72701, GHSA-38p6-h87p-r4cg Record: https://patchnext.com/advisories/cve-2026-72701 (revision 4, source checked 27 Oct 2026, 06:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 2.0.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getgrav/grav: affected < 2.0.16; fixed in 2.0.16 ## Suggested inspection (read-only) - Packagist getgrav/grav: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getgrav/grav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-38p6-h87p-r4cg (OSV record GHSA-38p6-h87p-r4cg lists affected ranges: Packagist getgrav/grav >=0 <2.0.16 (fixed)) - Verified: https://github.com/advisories/GHSA-38p6-h87p-r4cg (GitHub-reviewed advisory GHSA-38p6-h87p-r4cg lists affected ranges: Packagist getgrav/grav >=0 <=2.0.15) Commands are suggestions: review each one before running it.
Loading voting…