Ruby JSON: JSON::ResumableParser#partial_value dereferences a freed input buffer and crashes on truncated duplicate-key streams
CVE-2026-71847GHSA-9hj4-r449-hfvc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (json 2.21.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems json
- Affected
- >= 2.20.0, <= 2.21.1
- Fixed in
- 2.21.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9hj4-r449-hfvc lists affected ranges: RubyGems json >=2.20.0 <2.21.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9hj4-r449-hfvc lists affected ranges: RubyGems json >=2.20.0 <=2.21.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-71847: 0.43% estimated exploitation activity in the next 30 days; percentile 37.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Ruby's JSON native C extension clears the consumed JSON::ResumableParser input buffer but leaves state.start, state.cursor, and state.end pointing into released storage. When partialvalue reconstructs an incomplete object containing duplicate keys, the duplicate-key warning path calls cursorposition, which dereferences those stale pointers. This results in a heap-use-after-free and can terminate the Ruby process. An attacker who can supply JSON stream data to an application using JSON::ResumableParser may cause process termination when the application calls partialvalue on incomplete attacker-controlled input containing duplicate object keys. The issue was reproduced in the native C extension from the official RubyGems releases: JSON 2.20.0 JSON 2.21.0 JSON 2.21.1 The attached evidence demonstrates: an AddressSanitizer-confirmed heap-use-after-free; a native SIGSEGV using the official JSON 2.21.1 RubyGem; an end-to-end loopback TCP attacker/victim reproduction; four…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9hj4-r449-hfvc
- Revision 1 · created ·
Published from osv record GHSA-9hj4-r449-hfvc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-71847 Advisory: Ruby JSON: JSON::ResumableParser#partial_value dereferences a freed input buffer and crashes on truncated duplicate-key streams IDs: CVE-2026-71847, GHSA-9hj4-r449-hfvc Record: https://patchnext.com/advisories/cve-2026-71847 (revision 2, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: json 2.21.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems json: affected >= 2.20.0, <= 2.21.1; fixed in 2.21.2 ## Suggested inspection (read-only) - RubyGems json: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on json. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9hj4-r449-hfvc (OSV record GHSA-9hj4-r449-hfvc lists affected ranges: RubyGems json >=2.20.0 <2.21.2 (fixed)) - Verified: https://github.com/advisories/GHSA-9hj4-r449-hfvc (GitHub-reviewed advisory GHSA-9hj4-r449-hfvc lists affected ranges: RubyGems json >=2.20.0 <=2.21.1) Commands are suggestions: review each one before running it.
Loading voting…