@cyclonedx/cyclonedx-npm: Shell Injection via Unsanitized --workspace Argument on Windows
CVE-2026-71538GHSA-q69g-4hcv-6jg4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@cyclonedx/cyclonedx-npm 6.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 6.0.0
- Fixed in
- 6.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q69g-4hcv-6jg4 lists affected ranges: npm @cyclonedx/cyclonedx-npm >=0 <6.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q69g-4hcv-6jg4 lists affected ranges: npm @cyclonedx/cyclonedx-npm >=0 <6.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-71538: 0.21% estimated exploitation activity in the next 30 days; percentile 11.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Windows-specific command injection vulnerability exists in @cyclonedx/cyclonedx-npm when the CLI is invoked with the --workspace <value option. User-supplied --workspace values can be passed to a shell command without proper neutralization on the Windows fallback execution path, enabling attackers to inject arbitrary OS commands. The vulnerability was fixed in version [6.0.0][v6.0.0]. Vulnerability Details When cyclonedx-npm is executed with the --workspace option, the provided argument is incorporated into an internal command execution flow. On Windows systems, this path can interpret untrusted --workspace input as shell syntax if not safely handled. As a result, specially crafted workspace names can break out of the intended command context and execute arbitrary commands with the privileges of the invoking user. Impact An attacker who can influence the value passed to --workspace can execute arbitrary OS commands on Windows hosts. This may lead to: Arbitrary command…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-q69g-4hcv-6jg4
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-q69g-4hcv-6jg4
- Revision 1 · created ·
Published from ghsa record GHSA-q69g-4hcv-6jg4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-71538 Advisory: @cyclonedx/cyclonedx-npm: Shell Injection via Unsanitized --workspace Argument on Windows IDs: CVE-2026-71538, GHSA-q69g-4hcv-6jg4 Record: https://patchnext.com/advisories/cve-2026-71538 (revision 4, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @cyclonedx/cyclonedx-npm 6.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @cyclonedx/cyclonedx-npm: affected < 6.0.0; fixed in 6.0.0 ## Suggested inspection (read-only) - `npm ls @cyclonedx/cyclonedx-npm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @cyclonedx/cyclonedx-npm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q69g-4hcv-6jg4 (GitHub-reviewed advisory GHSA-q69g-4hcv-6jg4 lists affected ranges: npm @cyclonedx/cyclonedx-npm >=0 <6.0.0) - Verified: https://osv.dev/vulnerability/GHSA-q69g-4hcv-6jg4 (OSV record GHSA-q69g-4hcv-6jg4 lists affected ranges: npm @cyclonedx/cyclonedx-npm >=0 <6.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…