Skip to content

← Actionable
Medium, CVSS 6.5amended

Paymenter has a credit-refund double-spend race condition in service downgrade (doUpgrade)

CVE-2026-71537GHSA-5gmm-hjfj-8ff7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (paymenter/paymenter 1.5.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-71537: 0.33% estimated exploitation activity in the next 30 days; percentile 25.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The service downgrade implementation in app/Livewire/Services/Upgrade.php::doUpgrade() executes a proration calculation and a subsequent user credit refund without any transactional safety or database locks. The only concurrency check relies on an unisolated database query checking for existing pending upgrades. Because there is no active database transaction or pessimistic row-level lock spanning this validation and the subsequent credit update, concurrent downgrade requests can bypass the guard simultaneously. This allows a user to trigger multiple refunds for a single service downgrade. Technical Details The issue occurs because the application verifies eligibility using an unlocked read operation (Service::upgradable) which checks if a pending upgrade row exists. Since there is no enclosing DB::transaction or lockForUpdate(), multiple requests sent in parallel can all query the database at the same millisecond, observe that no pending upgrade exists, and pass the safety…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5gmm-hjfj-8ff7

  2. Revision 1 · created ·

    Published from osv record GHSA-5gmm-hjfj-8ff7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-71537

Advisory: Paymenter has a credit-refund double-spend race condition in service downgrade (doUpgrade)
IDs: CVE-2026-71537, GHSA-5gmm-hjfj-8ff7
Record: https://patchnext.com/advisories/cve-2026-71537 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: paymenter/paymenter 1.5.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist paymenter/paymenter: affected <= 1.5.6; fixed in 1.5.7

## Suggested inspection (read-only)
- Packagist paymenter/paymenter: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on paymenter/paymenter.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5gmm-hjfj-8ff7 (OSV record GHSA-5gmm-hjfj-8ff7 lists affected ranges: Packagist paymenter/paymenter >=0 <1.5.7 (fixed))
- Verified: https://github.com/advisories/GHSA-5gmm-hjfj-8ff7 (GitHub-reviewed advisory GHSA-5gmm-hjfj-8ff7 lists affected ranges: Packagist paymenter/paymenter >=0 <=1.5.6)

Commands are suggestions: review each one before running it.

Loading voting…