Skip to content

← Actionable
High, CVSS 7.5amended

league/commonmark: Quadratic-time denial of service when parsing crafted Markdown

CVE-2026-71488GHSA-2q4p-g7hv-5rgv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (league/commonmark 2.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-71488: 0.63% estimated exploitation activity in the next 30 days; percentile 50.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Affected versions of league/commonmark can have quadratic time complexity when parsing specially crafted Markdown lines. In practical terms, doubling the length of an affected line can make the parser perform roughly four times as much work. The parser identifies locations using character positions, but regular-expression matches report byte positions. These positions differ when a UTF-8 character uses more than one byte. Several parsing paths repeatedly rescan growing portions of the line to translate between the two positions. The Autolink extension can also copy and validate the remaining line at every URL-like prefix. In current 2.x releases, a single non-ASCII character anywhere on a line can place that whole line on the slower multibyte path. An attacker can combine it with a long run of leading whitespace or repeated Markdown punctuation, causing increasingly large rescans. When the Autolink extension is enabled, repeated URL-like prefixes provide another trigger, even…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2q4p-g7hv-5rgv

  2. Revision 1 · created ·

    Published from osv record GHSA-2q4p-g7hv-5rgv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-71488

Advisory: league/commonmark: Quadratic-time denial of service when parsing crafted Markdown
IDs: CVE-2026-71488, GHSA-2q4p-g7hv-5rgv
Record: https://patchnext.com/advisories/cve-2026-71488 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: league/commonmark 2.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist league/commonmark: affected >= 0.6.0, < 2.9.0; fixed in 2.9.0

## Suggested inspection (read-only)
- Packagist league/commonmark: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on league/commonmark.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2q4p-g7hv-5rgv (OSV record GHSA-2q4p-g7hv-5rgv lists affected ranges: Packagist league/commonmark >=0.6.0 <2.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2q4p-g7hv-5rgv (GitHub-reviewed advisory GHSA-2q4p-g7hv-5rgv lists affected ranges: Packagist league/commonmark >=0.6.0 <2.9.0)

Commands are suggestions: review each one before running it.

Loading voting…