Skip to content

← Actionable
Medium, CVSS 5.3

Mermaid radar diagrams are vulnerable to DoS

CVE-2026-71439GHSA-rhh3-jpg6-66xh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mermaid 11.16.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mermaid

    Affected
    >= 11.6.0, < 11.16.1
    Fixed in
    11.16.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L · score source
EPSS
  • CVE-2026-71439: 0.53% estimated exploitation activity in the next 30 days; percentile 44.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Mermaid radar diagrams allow arbitrary large values for ticks, which can cause high CPU usage, freezing the webpage/JavaScript process for long periods of time, until the process is eventually killed due to OOM/running out of memory. Proof-of-concept Patches Has the problem been patched? What versions should users upgrade to? This problem has been patched by https://github.com/mermaid-js/mermaid/commit/59b22fad2b3bb04f87a476c84a8a2b24679e607e, which was released in Mermaid v11.16.1 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? There are no known workarounds without updating to a patched version of mermaid. References Are there any links users can visit to find out more? - https://github.com/mermaid-js/mermaid/commit/59b22fad2b3bb04f87a476c84a8a2b24679e607e - https://github.com/mermaid-js/mermaid/releases/tag/mermaid%4011.16.1

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rhh3-jpg6-66xh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-71439

Advisory: Mermaid radar diagrams are vulnerable to DoS
IDs: CVE-2026-71439, GHSA-rhh3-jpg6-66xh
Record: https://patchnext.com/advisories/cve-2026-71439 (revision 1, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mermaid 11.16.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mermaid: affected >= 11.6.0, < 11.16.1; fixed in 11.16.1

## Suggested inspection (read-only)
- `npm ls mermaid --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mermaid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rhh3-jpg6-66xh (GitHub-reviewed advisory GHSA-rhh3-jpg6-66xh lists affected ranges: npm mermaid >=11.6.0 <11.16.1)

Commands are suggestions: review each one before running it.

Loading voting…