Mermaid configuration APIs allow prototype pollution
CVE-2026-71438GHSA-c4c3-pg64-4m4v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mermaid 11.16.1, 10.9.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mermaid
- Affected
- >= 11.0.0-alpha.1, < 11.16.1< 10.9.8
- Fixed in
- 10.9.8, 11.16.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c4c3-pg64-4m4v lists affected ranges: npm mermaid >=11.0.0-alpha.1 =0 <10.9.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.4 · CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:A/VC:N/VI:L/VA:L/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-71438: 0.35% estimated exploitation activity in the next 30 days; percentile 29.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Mermaid's configuration setters (mermaid.initialize, mermaidAPI.setConfig, and mermaidAPI.updateSiteConfig) merge the caller-supplied configuration object into Mermaid's internal config using the assignWithDepth deep-merge helper that is vulnerable to prototype pollution. Because these APIs are intended to receive trusted configuration supplied by the application integrating Mermaid, Mermaid assesses the practical risk as low. The vulnerability is only reachable if an application forwards attacker-controlled data directly into one of these configuration entry points, which is outside their documented usage. User-controlled configuration (e.g. configuration in diagram code using %%{init: {}}%% or YAML frontmatter) are already protected from prototype pollution. Patches This has been patched in https://github.com/mermaid-js/mermaid/commit/2cd6dcf735533b323507e3e889ffdea870540b43 and released in Mermaid v11.16.1. A backport has been made for the v10 branch in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c4c3-pg64-4m4v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-71438 Advisory: Mermaid configuration APIs allow prototype pollution IDs: CVE-2026-71438, GHSA-c4c3-pg64-4m4v Record: https://patchnext.com/advisories/cve-2026-71438 (revision 1, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mermaid 11.16.1, 10.9.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mermaid: affected >= 11.0.0-alpha.1, < 11.16.1; < 10.9.8; fixed in 10.9.8, 11.16.1 ## Suggested inspection (read-only) - `npm ls mermaid --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mermaid. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c4c3-pg64-4m4v (GitHub-reviewed advisory GHSA-c4c3-pg64-4m4v lists affected ranges: npm mermaid >=11.0.0-alpha.1 =0 <10.9.8) Commands are suggestions: review each one before running it.
Loading voting…