Skip to content

← Actionable
Medium, CVSS 6.5

Mermaid Architecture diagrams are vulnerable to prototype pollution

CVE-2026-71437GHSA-3rrr-jr9j-h3q3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mermaid 11.16.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mermaid

    Affected
    >= 11.5.0, < 11.16.1
    Fixed in
    11.16.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-71437: 0.50% estimated exploitation activity in the next 30 days; percentile 43.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Rendering an untrusted architecture-beta diagram lets the diagram author write an arbitrary property with the value horizontal or vertical onto Object.prototype. A group id of proto is accepted as a valid parent. Impact Any code in the same realm that reads a property of that name from an arbitrary object, or enumerates an object with bare for...in, observes the injected value (which can only be the string horizontal or vertical. This may mean corrupted option/config defaults, bypassed truthiness checks, causing denial of service or logic corruption in the embedding application. Because the injected value cannot be an object or function, this is not directly exploitable for remote code execution. PoC The vulnerable write was introduced in commit cb0a4703bdf01d47508bde1c08aa9a980d70bc20 and first shipped in mermaid@11.5.0. The lines are unchanged in every release since. Patches This has been patched by…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3rrr-jr9j-h3q3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-71437

Advisory: Mermaid Architecture diagrams are vulnerable to prototype pollution
IDs: CVE-2026-71437, GHSA-3rrr-jr9j-h3q3
Record: https://patchnext.com/advisories/cve-2026-71437 (revision 1, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mermaid 11.16.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mermaid: affected >= 11.5.0, < 11.16.1; fixed in 11.16.1

## Suggested inspection (read-only)
- `npm ls mermaid --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mermaid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3rrr-jr9j-h3q3 (GitHub-reviewed advisory GHSA-3rrr-jr9j-h3q3 lists affected ranges: npm mermaid >=11.5.0 <11.16.1)

Commands are suggestions: review each one before running it.

Loading voting…