Mermaid XY Charts are vulnerable to an infinite loop DoS
CVE-2026-71436GHSA-2v8p-3f2j-5mp7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mermaid 11.16.1, 10.9.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mermaid
- Affected
- >= 10.6.0, < 10.9.8>= 11.0.0-alpha.1, < 11.16.1
- Fixed in
- 10.9.8, 11.16.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2v8p-3f2j-5mp7 lists affected ranges: npm mermaid >=10.6.0 =11.0.0-alpha.1 <11.16.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2v8p-3f2j-5mp7 lists affected ranges: npm mermaid >=10.6.0 =11.0.0-alpha.1 <11.16.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L · score source
- EPSS
- CVE-2026-71436: 0.58% estimated exploitation activity in the next 30 days; percentile 47.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Mermaid XY Charts are vulnerable to an infinite loop DoS attack in the setXAxisRangeData(), when configuring an X-Axis with invalid parameters. As each loop appends an element to an array, this would generally only cause an RangeError: Invalid array length to appear after a few seconds, but may cause the page/JavaScript process to crash due to memory exhaustion, depending on the environment. Proof-of-concept Patches This has been patched in https://github.com/mermaid-js/mermaid/commit/630aa7e5dd417e1f56bff2a1ce8df2c5ad08d289 and released in Mermaid v11.16.1. A backport has been made for the v10 branch in ef60adc837d9d5107af21285f01e83dea309bd0a and was released in Mermaid v10.9.8 Workarounds There are no known workarounds. Please update to the latest version or apply the patch. References - https://github.com/mermaid-js/mermaid/commit/630aa7e5dd417e1f56bff2a1ce8df2c5ad08d289 - https://github.com/mermaid-js/mermaid/releases/tag/mermaid%4011.16.1 -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2v8p-3f2j-5mp7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-2v8p-3f2j-5mp7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-71436 Advisory: Mermaid XY Charts are vulnerable to an infinite loop DoS IDs: CVE-2026-71436, GHSA-2v8p-3f2j-5mp7 Record: https://patchnext.com/advisories/cve-2026-71436 (revision 3, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mermaid 11.16.1, 10.9.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mermaid: affected >= 10.6.0, < 10.9.8; >= 11.0.0-alpha.1, < 11.16.1; fixed in 10.9.8, 11.16.1 ## Suggested inspection (read-only) - `npm ls mermaid --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mermaid. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2v8p-3f2j-5mp7 (OSV record GHSA-2v8p-3f2j-5mp7 lists affected ranges: npm mermaid >=10.6.0 =11.0.0-alpha.1 <11.16.1 (fixed)) - Verified: https://github.com/advisories/GHSA-2v8p-3f2j-5mp7 (GitHub-reviewed advisory GHSA-2v8p-3f2j-5mp7 lists affected ranges: npm mermaid >=10.6.0 =11.0.0-alpha.1 <11.16.1) Commands are suggestions: review each one before running it.
Loading voting…