Kirby: File upload permissions are not checked during processing of chunk data
CVE-2026-71415GHSA-67mx-6wf2-92xp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 5.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getkirby/cms
- Affected
- >= 5.0.0, < 5.5.2
- Fixed in
- 5.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-67mx-6wf2-92xp lists affected ranges: Packagist getkirby/cms >=5.0.0 <5.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-67mx-6wf2-92xp lists affected ranges: Packagist getkirby/cms >=5.0.0 <5.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-71415: 0.43% estimated exploitation activity in the next 30 days; percentile 37.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
TL;DR This vulnerability affects all Kirby sites where users of a particular role have access to the REST API (access.panel permission is enabled) but no permission to upload any kind of file (files.create, files.replace and user/users.update permissions are all disabled). It was possible to fill up the temporary directory for chunked uploads with unfinished chunks even as a user without any upload permission. This vulnerability is of high severity for affected sites. Your Kirby sites are not affected if you intend all users of your site to be able to upload files. The vulnerability can only be exploited by authenticated users. It was not possible to bypass the actual permission checks for any files that end up in the content or site/accounts folders. ---- Introduction Missing authorization allows authenticated users to perform actions they are not intended to have access to. The effects of missing authorization can include unauthorized access to sensitive information as well as…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-67mx-6wf2-92xp
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-67mx-6wf2-92xp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-71415 Advisory: Kirby: File upload permissions are not checked during processing of chunk data IDs: CVE-2026-71415, GHSA-67mx-6wf2-92xp Record: https://patchnext.com/advisories/cve-2026-71415 (revision 3, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 5.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getkirby/cms: affected >= 5.0.0, < 5.5.2; fixed in 5.5.2 ## Suggested inspection (read-only) - Packagist getkirby/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getkirby/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-67mx-6wf2-92xp (OSV record GHSA-67mx-6wf2-92xp lists affected ranges: Packagist getkirby/cms >=5.0.0 <5.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-67mx-6wf2-92xp (GitHub-reviewed advisory GHSA-67mx-6wf2-92xp lists affected ranges: Packagist getkirby/cms >=5.0.0 <5.5.2) Commands are suggestions: review each one before running it.
Loading voting…