Skip to content

← Actionable
Medium, CVSS 4.3

Lemur: Missing authorization check on POST /certificates/ /export for plugins with requires_key = False

CVE-2026-71322GHSA-4h97-p9wq-chqj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lemur 1.9.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI lemur

    Affected
    < 1.9.3
    Fixed in
    1.9.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-71322: 0.23% estimated exploitation activity in the next 30 days; percentile 14.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The CertificateExport handler in lemur/certificates/views.py nests its entire ownership / CertificatePermission check inside an if plugin.requireskey: branch. When the selected export plugin advertises requireskey = False, the authorization check is skipped entirely and any authenticated user can invoke plugin.export(cert.body, cert.chain, cert.privatekey, options) against a certificate they do not own. The handler additionally writes a "keyview" audit-log event for every call, regardless of whether the plugin actually accessed the private key, polluting the audit trail with false positives. Root Cause lemur/certificates/views.py:1573: The authorization gate is structurally inside the if plugin.requireskey: block. With requireskey = False, control falls straight through to plugin.export(...) with no ownership check. The cert.privatekey is passed to the plugin regardless of the flag — the flag only describes what the plugin advertises it needs, not what it actually receives.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4h97-p9wq-chqj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-71322

Advisory: Lemur: Missing authorization check on POST /certificates/ /export for plugins with requires_key = False
IDs: CVE-2026-71322, GHSA-4h97-p9wq-chqj
Record: https://patchnext.com/advisories/cve-2026-71322 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lemur 1.9.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lemur: affected < 1.9.3; fixed in 1.9.3

## Suggested inspection (read-only)
- `python -m pip show lemur`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lemur.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4h97-p9wq-chqj (GitHub-reviewed advisory GHSA-4h97-p9wq-chqj lists affected ranges: PyPI lemur >=0 <1.9.3)

Commands are suggestions: review each one before running it.

Loading voting…