rclone: Incomplete path validation allows backend root escape in serve restic
CVE-2026-71309GHSA-45pq-889g-fcgh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rclone/rclone 1.75.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.40.0, < 1.75.0
- Fixed in
- 1.75.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-45pq-889g-fcgh lists affected ranges: Go github.com/rclone/rclone >=1.40.0 <1.75.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6184 lists affected ranges: Go github.com/rclone/rclone >=0 <1.75.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-45pq-889g-fcgh lists affected ranges: Go github.com/rclone/rclone >=1.40.0 <1.75.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-71309: 0.46% estimated exploitation activity in the next 30 days; percentile 39.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary rclone serve restic does not correctly reject URL paths beginning with ../. On affected backends, an attacker who can access the REST endpoint can read, create, overwrite, or delete objects outside the path configured by the operator. The issue affects rclone v1.40 through rclone v1.74.4. The proof of concept and backend matrix were validated with the official Linux AMD64 binary for v1.74.4, and the latest master commit reviewed at the time (2217d38) contained the same vulnerable validation. The main proof of concept uses WsgiDAV as an independent storage server and one rclone process. Affected versions All releases from v1.40 through v1.74.4 are affected. Affected components and backend propagation The primary vulnerable component is the backend-independent WithRemote middleware in cmd/serve/restic/restic.go, lines 235-264. It accepts a leading parent component and stores that unsafe relative path in the request context. The REST handlers then pass the same value to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-45pq-889g-fcgh
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GO-2026-6184
- Revision 1 · created ·
Published from osv record GHSA-45pq-889g-fcgh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-71309 Advisory: rclone: Incomplete path validation allows backend root escape in serve restic IDs: CVE-2026-71309, GHSA-45pq-889g-fcgh Record: https://patchnext.com/advisories/cve-2026-71309 (revision 4, source checked 26 Oct 2026, 15:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rclone/rclone 1.75.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rclone/rclone: affected >= 1.40.0, < 1.75.0; fixed in 1.75.0 ## Suggested inspection (read-only) - Go github.com/rclone/rclone: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rclone/rclone. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-45pq-889g-fcgh (OSV record GHSA-45pq-889g-fcgh lists affected ranges: Go github.com/rclone/rclone >=1.40.0 <1.75.0 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6184 (OSV record GO-2026-6184 lists affected ranges: Go github.com/rclone/rclone >=0 <1.75.0 (fixed)) - Verified: https://github.com/advisories/GHSA-45pq-889g-fcgh (GitHub-reviewed advisory GHSA-45pq-889g-fcgh lists affected ranges: Go github.com/rclone/rclone >=1.40.0 <1.75.0) Commands are suggestions: review each one before running it.
Loading voting…