Skip to content

← Actionable
High, CVSS 7.7

Lemur: Incomplete fix for GHSA-v2wp-frmc-5q3v -- ACME authority update endpoint allows non-admin to replace acme_url with internal IP, bypassing allowlist

CVE-2026-71303GHSA-v5rc-cpwc-cfpr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lemur 1.9.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI lemur

    Affected
    <= 1.9.2
    Fixed in
    1.9.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-71303: 0.28% estimated exploitation activity in the next 30 days; percentile 20.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The fix for GHSA-v2wp-frmc-5q3v added validateacmeurl() to reject acmeurl values not in ACMEDIRECTORYHOSTALLOWLIST, but the validation is only called at authority creation time (POST). The authority update endpoint (PUT /api/1/authorities/<id) accepts and stores arbitrary options -- including a modified acmeurl -- without invoking the allowlist check. Any user with an authority role (granted by an admin to allow issuing certificates via that authority) can therefore overwrite the stored acmeurl with an internal IP or IMDS endpoint. The next certificate issuance via that authority causes Lemur's backend to fetch the attacker-controlled URL, achieving SSRF. Details Where the fix lives (POST path -- protected): lemur/plugins/lemuracme/plugin.py lines 333-337 (ACMEIssuerPlugin.createauthority): validateacmeurl at line 35: Where the gap is (PUT path -- unprotected): lemur/authorities/views.py lines 405-424 (Authorities.put): lemur/authorities/service.py lines 28-46 (update): Where…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v5rc-cpwc-cfpr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-71303

Advisory: Lemur: Incomplete fix for GHSA-v2wp-frmc-5q3v -- ACME authority update endpoint allows non-admin to replace `acme_url` with internal IP, bypassing allowlist
IDs: CVE-2026-71303, GHSA-v5rc-cpwc-cfpr
Record: https://patchnext.com/advisories/cve-2026-71303 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lemur 1.9.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lemur: affected <= 1.9.2; fixed in 1.9.3

## Suggested inspection (read-only)
- `python -m pip show lemur`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lemur.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v5rc-cpwc-cfpr (GitHub-reviewed advisory GHSA-v5rc-cpwc-cfpr lists affected ranges: PyPI lemur >=0 <=1.9.2)

Commands are suggestions: review each one before running it.

Loading voting…