@fastify/static vulnerable to Authorization Bypass via Non-Canonical URL Paths
CVE-2026-7120GHSA-8pvw-jcv7-9cmj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/static 10.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @fastify/static
- Affected
- <= 10.1.1
- Fixed in
- 10.1.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8pvw-jcv7-9cmj lists affected ranges: npm @fastify/static >=0 <10.1.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8pvw-jcv7-9cmj lists affected ranges: npm @fastify/static >=0 <=10.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-7120: 0.37% estimated exploitation activity in the next 30 days; percentile 30.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact @fastify/static evaluates the allowedPath callback before normalizing dot segments and duplicate slashes in the pathname used for file resolution. Non-canonical pathnames such as //file, /./file, or /public/../private/file bypass allowedPath filtering while resolving to the intended file on disk. Applications that use allowedPath as a security boundary to restrict access to specific static files or path subtrees may unintentionally expose files that were intended to be denied. Patches Upgrade to @fastify/static = 10.1.2. Workarounds None. Upgrade to the patched version.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8pvw-jcv7-9cmj
- Revision 1 · created ·
Published from osv record GHSA-8pvw-jcv7-9cmj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-7120 Advisory: @fastify/static vulnerable to Authorization Bypass via Non-Canonical URL Paths IDs: CVE-2026-7120, GHSA-8pvw-jcv7-9cmj Record: https://patchnext.com/advisories/cve-2026-7120 (revision 2, source checked 26 Oct 2026, 12:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @fastify/static 10.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @fastify/static: affected <= 10.1.1; fixed in 10.1.2 ## Suggested inspection (read-only) - `npm ls @fastify/static --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @fastify/static. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8pvw-jcv7-9cmj (OSV record GHSA-8pvw-jcv7-9cmj lists affected ranges: npm @fastify/static >=0 <10.1.2 (fixed)) - Verified: https://github.com/advisories/GHSA-8pvw-jcv7-9cmj (GitHub-reviewed advisory GHSA-8pvw-jcv7-9cmj lists affected ranges: npm @fastify/static >=0 <=10.1.1) Commands are suggestions: review each one before running it.
Loading voting…