Skip to content

← Actionable
High, CVSS 7.4

Lemur: Server-Side Request Forgery via the ACME client following server-controlled URLs

CVE-2026-70666GHSA-xpmj-wjcp-6pww

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lemur 1.9.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI lemur

    Affected
    <= 1.9.2
    Fixed in
    1.9.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
EPSS
  • CVE-2026-70666: 0.22% estimated exploitation activity in the next 30 days; percentile 12.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The ACME client (used to issue certificates from Let's Encrypt / Google Public CA / private ACME CAs) connects to an acmeurl, then issues requests to URLs that the ACME server returns in its directory/order/authorization/finalize responses - this is the classic ACME-client SSRF (RFC 8555 design). Lemur validates acmeurl against an allowlist of public ACME directories, but only at authority creation. The authority UPDATE path (PUT /authorities/<id) accepts a new options blob with an arbitrary acmeurl and never re-validates. An attacker who is a member of an authority's role can repoint an existing ACME authority at a malicious ACME server they control, which returns internal URLs in its responses - coercing Lemur into making JWS-signed POST requests to internal services during the next certificate issuance. Detail Defect A - allowlist only at creation. validateacmeurl (lemur/plugins/lemuracme/plugin.py:35-53) restricts the host to {acme-v02.api.letsencrypt.org,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xpmj-wjcp-6pww

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-70666

Advisory: Lemur: Server-Side Request Forgery via the ACME client following server-controlled URLs
IDs: CVE-2026-70666, GHSA-xpmj-wjcp-6pww
Record: https://patchnext.com/advisories/cve-2026-70666 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lemur 1.9.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lemur: affected <= 1.9.2; fixed in 1.9.3

## Suggested inspection (read-only)
- `python -m pip show lemur`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lemur.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xpmj-wjcp-6pww (GitHub-reviewed advisory GHSA-xpmj-wjcp-6pww lists affected ranges: PyPI lemur >=0 <=1.9.2)

Commands are suggestions: review each one before running it.

Loading voting…