Skip to content

← Actionable
Medium, CVSS 6.6

Ghost: Theme Upload Path Traversal

CVE-2026-70593GHSA-cjc9-q5gf-327p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 6.54.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ghost

    Affected
    >= 0.10.0, < 6.54.1
    Fixed in
    6.54.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:L
EPSS
  • CVE-2026-70593: 0.41% estimated exploitation activity in the next 30 days; percentile 35.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability in custom themes allowed a staff user to write files outside of the uploads directory. This could be used to alter the behavior of the installation. Vulnerable versions This vulnerability is present in Ghost from v0.10.0 up to v6.54.0. Patches v6.54.1 contains a fix for this issue. How to update For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here. If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here. References Ghost thanks Stephen Sims, Off By One Security for disclosing this vulnerability responsibly. For more information If you have any questions or comments about this advisory, email Ghost at security@ghost.org.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cjc9-q5gf-327p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-70593

Advisory: Ghost: Theme Upload Path Traversal
IDs: CVE-2026-70593, GHSA-cjc9-q5gf-327p
Record: https://patchnext.com/advisories/cve-2026-70593 (revision 1, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ghost 6.54.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ghost: affected >= 0.10.0, < 6.54.1; fixed in 6.54.1

## Suggested inspection (read-only)
- `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ghost.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cjc9-q5gf-327p (GitHub-reviewed advisory GHSA-cjc9-q5gf-327p lists affected ranges: npm ghost >=0.10.0 <6.54.1)

Commands are suggestions: review each one before running it.

Loading voting…