Skip to content

← Actionable
Medium, CVSS 4.8

Ghost: Blind Password Hash Disclosure in Ghost Admin API

CVE-2026-70590GHSA-jm22-3w23-5q7w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 6.54.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ghost

    Affected
    < 6.54.1
    Fixed in
    6.54.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:H/A:N
EPSS
  • CVE-2026-70590: 0.32% estimated exploitation activity in the next 30 days; percentile 25.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Any staff-level user was able to leak the hashed passwords of other staff users. An offline password-guessing attack against the hashes could lead to account takeover if successful, but Device Verification should have prevented an attacker from logging in with a recovered password. Depending on the database used, leaked hashes may not have had the correct casing for all characters, increasing the difficulty of a password-guessing attack. Vulnerable versions This vulnerability is present in Ghost versions v6.54.0 and earlier. Patches v6.54.1 contains a fix for this issue. How to update For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here. If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here. Workarounds If upgrading immediately is not possible, ensure all staff users have Multi-factor Authentication (MFA) enabled. This will help prevent an attacker from…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jm22-3w23-5q7w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-70590

Advisory: Ghost: Blind Password Hash Disclosure in Ghost Admin API
IDs: CVE-2026-70590, GHSA-jm22-3w23-5q7w
Record: https://patchnext.com/advisories/cve-2026-70590 (revision 1, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ghost 6.54.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ghost: affected < 6.54.1; fixed in 6.54.1

## Suggested inspection (read-only)
- `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ghost.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jm22-3w23-5q7w (GitHub-reviewed advisory GHSA-jm22-3w23-5q7w lists affected ranges: npm ghost >=0 <6.54.1)

Commands are suggestions: review each one before running it.

Loading voting…