Skip to content

← Actionable
Medium, CVSS 5.0amended

Ghost: Cross-Site Scripting in Universal Import

CVE-2026-70588GHSA-2gx6-7gx2-wwcf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 6.54.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ghost

    Affected
    >= 5.26.0, < 6.54.1
    Fixed in
    6.54.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.0 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:H/A:L
EPSS
  • CVE-2026-70588: 0.43% estimated exploitation activity in the next 30 days; percentile 36.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Universal Import feature in Ghost Admin failed to properly sanitize imported content resulting in XSS in post content. Vulnerable versions This vulnerability is present in Ghost from v5.26.0 up to v6.54.0. Patches v6.54.1 contains a fix for this issue. How to update For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here. If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here. Workarounds If upgrading immediately is not possible, avoid using the Universal Import feature. References Ghost thanks meifukun for disclosing this vulnerability responsibly. For more information If you have any questions or comments about this advisory, email us at security@ghost.org.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2gx6-7gx2-wwcf

  2. Revision 1 · created ·

    Published from osv record GHSA-2gx6-7gx2-wwcf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-70588

Advisory: Ghost: Cross-Site Scripting in Universal Import
IDs: CVE-2026-70588, GHSA-2gx6-7gx2-wwcf
Record: https://patchnext.com/advisories/cve-2026-70588 (revision 2, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ghost 6.54.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ghost: affected >= 5.26.0, < 6.54.1; fixed in 6.54.1

## Suggested inspection (read-only)
- `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ghost.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2gx6-7gx2-wwcf (OSV record GHSA-2gx6-7gx2-wwcf lists affected ranges: npm ghost >=5.26.0 <6.54.1 (fixed))
- Verified: https://github.com/advisories/GHSA-2gx6-7gx2-wwcf (GitHub-reviewed advisory GHSA-2gx6-7gx2-wwcf lists affected ranges: npm ghost >=5.26.0 <6.54.1)

Commands are suggestions: review each one before running it.

Loading voting…