Open WebUI: Same-origin XSS to account takeover via terminal file-preview iframe hardcoding allow-same-origin
CVE-2026-70486GHSA-3xpf-xq7r-v8c5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI open-webui
- Affected
- >= 0.9.0, <= 0.10.2
- Fixed in
- 0.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3xpf-xq7r-v8c5 lists affected ranges: PyPI open-webui >=0.9.0 <=0.10.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-70486: 0.38% estimated exploitation activity in the next 30 days; percentile 32.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Any authenticated user with access to a terminal server could get script of their choosing to run in the Open WebUI origin itself. The HTML file preview rendered terminal-served files in an iframe whose sandbox always granted allow-same-origin alongside allow-scripts, and the file is served from a path on the application's own origin, so the sandbox provided no isolation at all. Script in a previewed file could read the victim's session token and take over the account. Preconditions - At least one terminal server configured by an admin (TERMINALSERVERCONNECTIONS, empty by default) and reachable by the victim. Deployments with no terminal server configured are not affected. - The attacker needs a normal authenticated account with access to that terminal server, no admin rights. - No victim interaction beyond having the chat open: a displayfile tool call opens the preview automatically. - TERMINALPROXYHEADERS unset, which is the default. An operator who had already set a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3xpf-xq7r-v8c5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-70486 Advisory: Open WebUI: Same-origin XSS to account takeover via terminal file-preview iframe hardcoding allow-same-origin IDs: CVE-2026-70486, GHSA-3xpf-xq7r-v8c5 Record: https://patchnext.com/advisories/cve-2026-70486 (revision 1, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: open-webui 0.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI open-webui: affected >= 0.9.0, <= 0.10.2; fixed in 0.11.0 ## Suggested inspection (read-only) - `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on open-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3xpf-xq7r-v8c5 (GitHub-reviewed advisory GHSA-3xpf-xq7r-v8c5 lists affected ranges: PyPI open-webui >=0.9.0 <=0.10.2) Commands are suggestions: review each one before running it.
Loading voting…