Skip to content

← Actionable
Critical, CVSS 9.2amended

Flowise: Unauthenticated OAuth2 token refresh endpoint returns access tokens — enables token theft for any connected service

CVE-2026-70478GHSA-qgvm-j2hm-6m38

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flowise

    Affected
    <= 3.1.2
    Fixed in
    3.1.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N · score source
EPSS
  • CVE-2026-70478: 0.61% estimated exploitation activity in the next 30 days; percentile 49.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The OAuth2 token refresh endpoint (POST /api/v1/oauth2-credential/refresh/:credentialId) is in WHITELISTURLS, meaning it requires no authentication. It decrypts the stored credential (containing clientId, clientSecret, refreshtoken), sends a refresh request to the configured OAuth provider, and returns the new accesstoken directly in the response body. Root Cause Whitelist entry at packages/server/src/utils/constants.ts:40. Attack Chain 1. Attacker obtains a credential ID (via Finding 2 / public chatflow leak, or enumeration) 2. Attacker calls POST /api/v1/oauth2-credential/refresh/:credentialId (no auth required) 3. Server decrypts credential, sends refresh request to OAuth provider with user's clientsecret 4. Server returns the new accesstoken in the response to the attacker 5. Attacker uses the token to access the victim's connected service (Google, Microsoft, etc.) Docker Validation POST /api/v1/oauth2-credential/refresh/fake-uuid returns {"message":"Credential not…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-qgvm-j2hm-6m38

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-qgvm-j2hm-6m38

  4. Revision 1 · created ·

    Published from ghsa record GHSA-qgvm-j2hm-6m38

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-70478

Advisory: Flowise: Unauthenticated OAuth2 token refresh endpoint returns access tokens — enables token theft for any connected service
IDs: CVE-2026-70478, GHSA-qgvm-j2hm-6m38
Record: https://patchnext.com/advisories/cve-2026-70478 (revision 4, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise 3.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise: affected <= 3.1.2; fixed in 3.1.3

## Suggested inspection (read-only)
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qgvm-j2hm-6m38 (GitHub-reviewed advisory GHSA-qgvm-j2hm-6m38 lists affected ranges: npm flowise >=0 <=3.1.2)
- Verified: https://osv.dev/vulnerability/GHSA-qgvm-j2hm-6m38 (OSV record GHSA-qgvm-j2hm-6m38 lists affected ranges: npm flowise >=0 <3.1.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…