Flowise: Cross-Workspace OAuth2 Credential Metadata Leak
CVE-2026-70474GHSA-wch5-xp77-fxg4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm flowise
- Affected
- <= 3.1.2
- Fixed in
- 3.1.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wch5-xp77-fxg4 lists affected ranges: npm flowise >=0 <=3.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-70474: 0.48% estimated exploitation activity in the next 30 days; percentile 41.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Three OAuth2 credential endpoints look up credentials by id alone with no workspaceId filter. Two of these endpoints (callback, refresh) are whitelisted from all authentication. This allows: 1. Cross-workspace credential access — Any authenticated user can initiate OAuth2 flows against credentials belonging to other workspaces. 2. Unauthenticated token injection — An unauthenticated attacker can forge OAuth2 callbacks to overwrite tokens in any credential. 3. Unauthenticated token refresh — An unauthenticated attacker can refresh tokens for any credential. --- Root Cause Vulnerable code: no workspace scoping All three OAuth2 handlers query the Credential table by id only: packages/server/src/routes/oauth2/index.ts:80-82 (authorize) packages/server/src/routes/oauth2/index.ts:183-185 (callback) packages/server/src/routes/oauth2/index.ts:314-316 (refresh) Correct pattern (same codebase) The standard credential service correctly enforces workspace isolation:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wch5-xp77-fxg4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-70474 Advisory: Flowise: Cross-Workspace OAuth2 Credential Metadata Leak IDs: CVE-2026-70474, GHSA-wch5-xp77-fxg4 Record: https://patchnext.com/advisories/cve-2026-70474 (revision 1, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flowise 3.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm flowise: affected <= 3.1.2; fixed in 3.1.3 ## Suggested inspection (read-only) - `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flowise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wch5-xp77-fxg4 (GitHub-reviewed advisory GHSA-wch5-xp77-fxg4 lists affected ranges: npm flowise >=0 <=3.1.2) Commands are suggestions: review each one before running it.
Loading voting…