authd: Primary group ID is incorrectly set to value of UID
CVE-2026-6970GHSA-fg3j-5w9g-hmg7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/canonical/authd 0.6.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.6.0, < 0.6.4
- Fixed in
- 0.6.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fg3j-5w9g-hmg7 lists affected ranges: Go github.com/canonical/authd >=0.6.0 <0.6.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-6970: 0.11% estimated exploitation activity in the next 30 days; percentile 1.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
authd 0.6.0 contains a bug which can lead to an incorrect primary group ID. It affects users whose primary group ID (i.e. the GID in the user record) differs from their UID. There are two ways which can lead to this: 1. The user was created with authd < 0.5.4 (released June 2025). Those users were created with UID != GID. 2. The primary group of the user was modified manually with the authctl utility that is shipped with authd (authctl group set-gid). Another condition is that some user information must have changed in the identity provider (else the user record is not updated upon login). If that is the case, the next time an affected user logs in, authd will set their primary group ID to their UID. This could lead to local privileges escalation. Also, files and directories created by those users will be owned by that incorrect primary group, which may grant other local users access to those files which they shouldn't have. Users who are affected by the issue can run this script to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fg3j-5w9g-hmg7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-6970 Advisory: authd: Primary group ID is incorrectly set to value of UID IDs: CVE-2026-6970, GHSA-fg3j-5w9g-hmg7 Record: https://patchnext.com/advisories/cve-2026-6970 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/canonical/authd 0.6.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/canonical/authd: affected >= 0.6.0, < 0.6.4; fixed in 0.6.4 ## Suggested inspection (read-only) - Go github.com/canonical/authd: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/canonical/authd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fg3j-5w9g-hmg7 (GitHub-reviewed advisory GHSA-fg3j-5w9g-hmg7 lists affected ranges: Go github.com/canonical/authd >=0.6.0 <0.6.4) Commands are suggestions: review each one before running it.
Loading voting…