Microsoft Security Advisory CVE-2026-69522 – .NET and Visual Studio Remote Code Execution Vulnerability
CVE-2026-69522GHSA-2j8r-3c22-8565
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (microsoft.diasymreader.native 18.9.0-beta1.26405.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet microsoft.diasymreader.native
- Affected
- >= 17.10.0-beta1.24272.1, < 18.9.0-beta1.26405.2
- Fixed in
- 18.9.0-beta1.26405.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2j8r-3c22-8565 lists affected ranges: NuGet microsoft.diasymreader.native >=17.10.0-beta1.24272.1 <18.9.0-beta1.26405.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2j8r-3c22-8565 lists affected ranges: NuGet microsoft.diasymreader.native >=17.10.0-beta1.24272.1 <=18.9.0-beta1.26405.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-69522: 0.84% estimated exploitation activity in the next 30 days; percentile 57.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Microsoft Security Advisory CVE-2026-69522 – .NET and Visual Studio Remote Code Execution Vulnerability
Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in Microsoft.DiaSymReader.Native. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. An out of bounds write can occur when processing PDB files.
Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/439
CVSS Details - Version: 3.1 - Severity: High - Score: 8.8 - Vector: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H` - Weakness: CWE-122 (Heap-based Buffer Overflow)
Affected Platforms - Platforms: Windows - Architectures: All
Affected Packages The vulnerability affects any Microsoft .NET project if it uses any of affected package versions listed below Supported .NET Framework versions listed in the Microsoft…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from osv record GHSA-2j8r-3c22-8565
- Revision 3 · amended ·
Amended from ghsa record GHSA-2j8r-3c22-8565
- Revision 2 · amended ·
Amended from ghsa record GHSA-2j8r-3c22-8565
- Revision 1 · created ·
Published from osv record GHSA-2j8r-3c22-8565
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-69522 Advisory: Microsoft Security Advisory CVE-2026-69522 – .NET and Visual Studio Remote Code Execution Vulnerability IDs: CVE-2026-69522, GHSA-2j8r-3c22-8565 Record: https://patchnext.com/advisories/cve-2026-69522 (revision 4, source checked 4 Nov 2026, 06:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: microsoft.diasymreader.native 18.9.0-beta1.26405.2. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet microsoft.diasymreader.native: affected >= 17.10.0-beta1.24272.1, < 18.9.0-beta1.26405.2; fixed in 18.9.0-beta1.26405.2 ## Suggested inspection (read-only) - NuGet microsoft.diasymreader.native: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on microsoft.diasymreader.native. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2j8r-3c22-8565 (OSV record GHSA-2j8r-3c22-8565 lists affected ranges: NuGet microsoft.diasymreader.native >=17.10.0-beta1.24272.1 <18.9.0-beta1.26405.2 (fixed)) - Verified: https://github.com/advisories/GHSA-2j8r-3c22-8565 (GitHub-reviewed advisory GHSA-2j8r-3c22-8565 lists affected ranges: NuGet microsoft.diasymreader.native >=17.10.0-beta1.24272.1 <=18.9.0-beta1.26405.1) Commands are suggestions: review each one before running it.
Loading voting…