Microsoft Security Advisory CVE-2026-69304 – ASP.NET Core Denial of Service Vulnerability
CVE-2026-69304GHSA-8cp2-47hg-mfgh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (microsoft.aspnetcore.server.iisintegration 11.0.0-rc.1, 10.0.12, 9.0.20, 8.0.31), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet microsoft.aspnetcore.server.iisintegration
- Affected
- >= 11.0.0-preview.1, < 11.0.0-rc.1>= 8.0.0, <= 8.0.30>= 9.0.0, <= 9.0.19>= 10.0.0, <= 10.0.11
- Fixed in
- 9.0.20, 10.0.12, 11.0.0-rc.1, 8.0.31
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8cp2-47hg-mfgh lists affected ranges: NuGet microsoft.aspnetcore.server.iisintegration >=11.0.0-preview.1 =8.0.0 =9.0.0 =10.0.0 <10.0.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8cp2-47hg-mfgh lists affected ranges: NuGet microsoft.aspnetcore.server.iisintegration >=11.0.0-preview.1 =8.0.0 =9.0.0 =10.0.0 <=10.0.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-69304: 0.85% estimated exploitation activity in the next 30 days; percentile 58.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Microsoft Security Advisory CVE-2026-69304 – ASP.NET Core Denial of Service Vulnerability Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in ASP.NET Core IIS out-of-process hosting and request decompression. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. The IIS Middleware for ASP.NET Core did not properly constrain decompression of certain types of request, leading to excess memory consumption and a Denial of Service. Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/443 CVSS Details - Version: 3.1 - Severity: Medium - Score: 5.9 - Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification)) Affected Platforms - Platforms: Windows / IIS out-of-process - Architectures: All <a name="affected-packages"</aAffected Packages…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8cp2-47hg-mfgh
- Revision 1 · created ·
Published from osv record GHSA-8cp2-47hg-mfgh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-69304 Advisory: Microsoft Security Advisory CVE-2026-69304 – ASP.NET Core Denial of Service Vulnerability IDs: CVE-2026-69304, GHSA-8cp2-47hg-mfgh Record: https://patchnext.com/advisories/cve-2026-69304 (revision 2, source checked 26 Oct 2026, 17:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: microsoft.aspnetcore.server.iisintegration 11.0.0-rc.1, 10.0.12, 9.0.20, 8.0.31. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet microsoft.aspnetcore.server.iisintegration: affected >= 11.0.0-preview.1, < 11.0.0-rc.1; >= 8.0.0, <= 8.0.30; >= 9.0.0, <= 9.0.19; >= 10.0.0, <= 10.0.11; fixed in 9.0.20, 10.0.12, 11.0.0-rc.1, 8.0.31 ## Suggested inspection (read-only) - NuGet microsoft.aspnetcore.server.iisintegration: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on microsoft.aspnetcore.server.iisintegration. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8cp2-47hg-mfgh (OSV record GHSA-8cp2-47hg-mfgh lists affected ranges: NuGet microsoft.aspnetcore.server.iisintegration >=11.0.0-preview.1 =8.0.0 =9.0.0 =10.0.0 <10.0.12 (fixed)) - Verified: https://github.com/advisories/GHSA-8cp2-47hg-mfgh (GitHub-reviewed advisory GHSA-8cp2-47hg-mfgh lists affected ranges: NuGet microsoft.aspnetcore.server.iisintegration >=11.0.0-preview.1 =8.0.0 =9.0.0 =10.0.0 <=10.0.11) Commands are suggestions: review each one before running it.
Loading voting…