python-cryptography: Duplicate self-signed intermediates can cause exponential path-building
CVE-2026-69249GHSA-jwv3-5hgf-82ww
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cryptography 49.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI cryptography
- Affected
- >= 42.0.0, < 49.0.0
- Fixed in
- 49.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jwv3-5hgf-82ww lists affected ranges: PyPI cryptography >=42.0.0 <49.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-69249: 0.26% estimated exploitation activity in the next 30 days; percentile 18.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When resolving invalid certificate chains that include duplicate copies of self-signed certificates, the processing recursively invokes the same candidate, leading to an exponential blowup. Although the limitation that the chain depth cannot exceed a specified maximum depth prevents unbounded recursion and guarantees termination, an attacker-controlled certificate chain can lead the processing to easily take more than 5s to reject in testing. This amplification could form the basis for a resource exhaustion denial of service attack. This work was completed by Trail of Bits as part of the Patch The Planet project in collaboration with OpenAI. The finding was identified primarily by the Codex coding agent, and manually reviewed before submission. Details The core issue arises in the recursive nature of buildchaininner, which does not de-duplicate against previously analyzed candidates. A sufficient patch is to track valid issuers, and to skip seen ones before recursing. By…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jwv3-5hgf-82ww
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-69249 Advisory: python-cryptography: Duplicate self-signed intermediates can cause exponential path-building IDs: CVE-2026-69249, GHSA-jwv3-5hgf-82ww Record: https://patchnext.com/advisories/cve-2026-69249 (revision 1, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cryptography 49.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI cryptography: affected >= 42.0.0, < 49.0.0; fixed in 49.0.0 ## Suggested inspection (read-only) - `python -m pip show cryptography`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cryptography. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jwv3-5hgf-82ww (GitHub-reviewed advisory GHSA-jwv3-5hgf-82ww lists affected ranges: PyPI cryptography >=42.0.0 <49.0.0) Commands are suggestions: review each one before running it.
Loading voting…