Skip to content

← Actionable
Critical, CVSS 9.8amended

Sequelize: SQL Injection (Oracle DB)

CVE-2026-69240GHSA-v8fg-2rw7-q452

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sequelize 6.37.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-69240: 0.54% estimated exploitation activity in the next 30 days; percentile 45.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary SQL Injection is possible with strings only if dialect is set to oracle. The vulnerability was confirmed on Sequelize v6.37.3. Details The escape function defined in sql-string.js does not escape quotes if the value starts with TOTIMESTAMP or TODATE. PoC Suppose the application has the following code: An attacker can inject arbitrary sql expressions. http://host/path?firstName=TODATE('0','Y')||'' OR 1=1-- The resulted SQL will be: Impact Data theft and tampering.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v8fg-2rw7-q452

  2. Revision 2 · amended ·

    Amended from osv record GHSA-v8fg-2rw7-q452

  3. Revision 1 · created ·

    Published from ghsa record GHSA-v8fg-2rw7-q452

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-69240

Advisory: Sequelize: SQL Injection (Oracle DB)
IDs: CVE-2026-69240, GHSA-v8fg-2rw7-q452
Record: https://patchnext.com/advisories/cve-2026-69240 (revision 3, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sequelize 6.37.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sequelize: affected < 6.37.4; fixed in 6.37.4

## Suggested inspection (read-only)
- `npm ls sequelize --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sequelize.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v8fg-2rw7-q452 (GitHub-reviewed advisory GHSA-v8fg-2rw7-q452 lists affected ranges: npm sequelize >=0 <6.37.4)
- Verified: https://osv.dev/vulnerability/GHSA-v8fg-2rw7-q452 (OSV record GHSA-v8fg-2rw7-q452 lists affected ranges: npm sequelize >=0 <6.37.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…