Skip to content

← Actionable
High, CVSS 8.7amended

RabbitMQ Java client ValueReader: Oversized LongString/bytes length triggers OOM via unchecked allocation

CVE-2026-69219GHSA-68mj-5wr7-6fgg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.rabbitmq:amqp-client 5.33.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-69219: 0.73% estimated exploitation activity in the next 30 days; percentile 54.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary ValueReader.readBytes() allocates a byte array sized by a wire-declared content length without validating it against actual frame data. A malicious AMQP peer triggers OOM by declaring a ~2GB string/bytes field. Vulnerable Code src/main/java/com/rabbitmq/client/impl/ValueReader.java lines 83-95: Attack Scenario A malicious AMQP server sends a LongString field (type tag 'S') with declared length 0x7FFFFFFE (2,147,483,646). The check contentLength < Integer.MAXVALUE passes. new byte[2147483646] attempts ~2GB allocation, causing OutOfMemoryError before readFully() attempts to read data. The allocation size is attacker-controlled and is NOT validated against the frame size or TruncatedInputStream bounds. Exploitable pre-authentication via connection.start server-properties table. Impact Denial of service via JVM OutOfMemoryError. Crashes the entire JVM. CWE CWE-789: Memory Allocation with Excessive Size Value Remediation Validate contentLength against the frame's remaining bytes…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-68mj-5wr7-6fgg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-68mj-5wr7-6fgg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-69219

Advisory: RabbitMQ Java client ValueReader: Oversized LongString/bytes length triggers OOM via unchecked allocation
IDs: CVE-2026-69219, GHSA-68mj-5wr7-6fgg
Record: https://patchnext.com/advisories/cve-2026-69219 (revision 3, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.rabbitmq:amqp-client 5.33.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.rabbitmq:amqp-client: affected <= 5.33.0; fixed in 5.33.1

## Suggested inspection (read-only)
- Maven com.rabbitmq:amqp-client: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.rabbitmq:amqp-client.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-68mj-5wr7-6fgg (OSV record GHSA-68mj-5wr7-6fgg lists affected ranges: Maven com.rabbitmq:amqp-client >=0 <5.33.1 (fixed))
- Verified: https://github.com/advisories/GHSA-68mj-5wr7-6fgg (GitHub-reviewed advisory GHSA-68mj-5wr7-6fgg lists affected ranges: Maven com.rabbitmq:amqp-client >=0 <=5.33.0)

Commands are suggestions: review each one before running it.

Loading voting…