Http4s: DigestAuth nonce map grows unbounded
CVE-2026-69208GHSA-fm4g-76c9-7w69
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.http4s:http4s-ember-server_2.13 1.0.0-M47, 0.23.35; org.http4s:http4s-ember-server_3 1.0.0-M47, 0.23.35; org.http4s:http4s-ember-server_2.12 0.23.35), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.http4s:http4s-ember-server_2.13
- Affected
- <= 0.23.34>= 1.0.0-M1, <= 1.0.0-M46
- Fixed in
- 0.23.35, 1.0.0-M47
Maven org.http4s:http4s-ember-server_3
- Affected
- <= 0.23.34>= 1.0.0-M1, <= 1.0.0-M46
- Fixed in
- 0.23.35, 1.0.0-M47
Maven org.http4s:http4s-ember-server_2.12
- Affected
- <= 0.23.34
- Fixed in
- 0.23.35
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fm4g-76c9-7w69 lists affected ranges: Maven org.http4s:http4s-ember-server_2.12 >=0 =0 =1.0.0-M1 =0 =1.0.0-M1 <1.0.0-M47 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fm4g-76c9-7w69 lists affected ranges: Maven org.http4s:http4s-ember-server_2.12 >=0 =0 =1.0.0-M1 =0 =1.0.0-M1 <=1.0.0-M46
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-69208: 0.77% estimated exploitation activity in the next 30 days; percentile 55.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The DigestAuth server middleware's stale-nonce cleanup uses an inverted comparison: it removes fresh nonces and stops at the first stale one. Because a new nonce is created for every unauthenticated challenge, an attacker can drive the nonce map to grow without bound until the JVM runs out of heap. Impact Unauthenticated remote denial of service (gradual heap exhaustion / OOM) against any service using DigestAuth. The leak is persistent. Preconditions - Application uses DigestAuth on at least one route. Workarounds - Front the DigestAuth protected routes with a rate limiter to slow the leak. - Restart periodically. Fixes - The eviction logic is corrected. - A max cache size of 1000000 is imposed to protected against a burst between evictions. This limit is not yet configurable.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fm4g-76c9-7w69
- Revision 1 · created ·
Published from osv record GHSA-fm4g-76c9-7w69
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-69208 Advisory: Http4s: DigestAuth nonce map grows unbounded IDs: CVE-2026-69208, GHSA-fm4g-76c9-7w69 Record: https://patchnext.com/advisories/cve-2026-69208 (revision 2, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.http4s:http4s-ember-server_2.13 1.0.0-M47, 0.23.35; org.http4s:http4s-ember-server_3 1.0.0-M47, 0.23.35; org.http4s:http4s-ember-server_2.12 0.23.35. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.http4s:http4s-ember-server_2.13: affected <= 0.23.34; >= 1.0.0-M1, <= 1.0.0-M46; fixed in 0.23.35, 1.0.0-M47 - Maven org.http4s:http4s-ember-server_3: affected <= 0.23.34; >= 1.0.0-M1, <= 1.0.0-M46; fixed in 0.23.35, 1.0.0-M47 - Maven org.http4s:http4s-ember-server_2.12: affected <= 0.23.34; fixed in 0.23.35 ## Suggested inspection (read-only) - Maven org.http4s:http4s-ember-server_2.13: check the installed version with your package manager. - Maven org.http4s:http4s-ember-server_3: check the installed version with your package manager. - Maven org.http4s:http4s-ember-server_2.12: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.http4s:http4s-ember-server_2.13, org.http4s:http4s-ember-server_3, org.http4s:http4s-ember-server_2.12. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fm4g-76c9-7w69 (OSV record GHSA-fm4g-76c9-7w69 lists affected ranges: Maven org.http4s:http4s-ember-server_2.12 >=0 =0 =1.0.0-M1 =0 =1.0.0-M1 <1.0.0-M47 (fixed)) - Verified: https://github.com/advisories/GHSA-fm4g-76c9-7w69 (GitHub-reviewed advisory GHSA-fm4g-76c9-7w69 lists affected ranges: Maven org.http4s:http4s-ember-server_2.12 >=0 =0 =1.0.0-M1 =0 =1.0.0-M1 <=1.0.0-M46) Commands are suggestions: review each one before running it.
Loading voting…