Angular i18n: Cross-Site Scripting (XSS) via event-handler attributes
CVE-2026-69151GHSA-jj27-h5hq-8x99
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 22.0.0-next.0, < 22.0.1>= 21.0.0-next.0, < 21.2.19>= 20.0.0-next.0, < 20.3.27<= 19.2.25
- Fixed in
- 22.0.1, 21.2.19, 20.3.27
npm @angular/core
- Affected
- >= 22.0.0-next.0, < 22.0.1>= 21.0.0-next.0, < 21.2.19>= 20.0.0-next.0, < 20.3.27<= 19.2.25
- Fixed in
- 22.0.1, 21.2.19, 20.3.27
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jj27-h5hq-8x99 lists affected ranges: npm @angular/compiler >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =0 =22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =0 <=19.2.25
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-69151: 0.33% estimated exploitation activity in the next 30 days; percentile 26.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Cross-Site Scripting (XSS) vulnerability has been identified in the Angular compiler's internationalization (i18n) pipeline. Although Angular disallows binding to event-handler attributes such as onclick and onerror through standard attribute validation (validateAttribute() / validateProperty()), the i18n metadata collection path allowed these same attribute names to be marked for translation using i18n-on attributes (e.g., i18n-onerror). When exploited, a lower-trust translation file could replace a benign static handler such as onerror="void 0" with arbitrary executable JavaScript in the localized build. The following example illustrates a vulnerable pattern: Impact When exploited, this vulnerability allows arbitrary JavaScript execution within the context of the vulnerable application's domain if an attacker can control or influence the translation files used during localization. This can lead to: - Session Hijacking: Accessing session cookies, tokens, or sensitive user data. -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jj27-h5hq-8x99
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-69151 Advisory: Angular i18n: Cross-Site Scripting (XSS) via event-handler attributes IDs: CVE-2026-69151, GHSA-jj27-h5hq-8x99 Record: https://patchnext.com/advisories/cve-2026-69151 (revision 1, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @angular/compiler 22.0.1, 21.2.19, 20.3.27; @angular/core 22.0.1, 21.2.19, 20.3.27. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/compiler: affected >= 22.0.0-next.0, < 22.0.1; >= 21.0.0-next.0, < 21.2.19; >= 20.0.0-next.0, < 20.3.27; <= 19.2.25; fixed in 22.0.1, 21.2.19, 20.3.27 - npm @angular/core: affected >= 22.0.0-next.0, < 22.0.1; >= 21.0.0-next.0, < 21.2.19; >= 20.0.0-next.0, < 20.3.27; <= 19.2.25; fixed in 22.0.1, 21.2.19, 20.3.27 ## Suggested inspection (read-only) - `npm ls @angular/compiler --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @angular/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/compiler, @angular/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jj27-h5hq-8x99 (GitHub-reviewed advisory GHSA-jj27-h5hq-8x99 lists affected ranges: npm @angular/compiler >=22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =0 =22.0.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =0 <=19.2.25) Commands are suggestions: review each one before running it.
Loading voting…