vLLM: Request-selected PyNvVideoCodec GPU decode bypasses static VRAM reservation
CVE-2026-69147GHSA-8pw2-6jv3-mj5j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.28.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- < 0.28.0
- Fixed in
- 0.28.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8pw2-6jv3-mj5j lists affected ranges: PyPI vllm >=0 <0.28.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8pw2-6jv3-mj5j lists affected ranges: PyPI vllm >=0 <0.28.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-69147: 0.58% estimated exploitation activity in the next 30 days; percentile 47.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Current vLLM main lets an inference request choose the PyNvVideoCodec GPU video decoder through mediaiokwargs.video.videobackend, but engine GPU memory reservation is computed only from static startup configuration and VLLMVIDEOLOADERBACKEND. If the server starts with the default OpenCV/software backend and no --mm-ipc-gpu-memory-gb budget, a client can still route a video request into the PyNvVideoCodec path after startup, causing frontend CUDA-context, decoder-surface, and decoded-frame GPU allocations that were not carved out of the engine KV-cache budget. Technical Details The vulnerable boundary is the split between request-time media decoding choices in the API server and startup-time memory budgeting in the engine worker. Request bodies for Chat Completions and Responses expose mediaiokwargs, and those values are forwarded to the shared media connector. For video inputs, MediaConnector.fetchvideo() copies self.mediaiokwargs["video"] into videoiokwargs, only setting a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8pw2-6jv3-mj5j
- Revision 2 · amended ·
Amended from osv record GHSA-8pw2-6jv3-mj5j
- Revision 1 · created ·
Published from ghsa record GHSA-8pw2-6jv3-mj5j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-69147 Advisory: vLLM: Request-selected PyNvVideoCodec GPU decode bypasses static VRAM reservation IDs: CVE-2026-69147, GHSA-8pw2-6jv3-mj5j Record: https://patchnext.com/advisories/cve-2026-69147 (revision 3, source checked 26 Oct 2026, 13:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.28.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected < 0.28.0; fixed in 0.28.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8pw2-6jv3-mj5j (GitHub-reviewed advisory GHSA-8pw2-6jv3-mj5j lists affected ranges: PyPI vllm >=0 <0.28.0) - Verified: https://osv.dev/vulnerability/GHSA-8pw2-6jv3-mj5j (OSV record GHSA-8pw2-6jv3-mj5j lists affected ranges: PyPI vllm >=0 <0.28.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…