GitPython: git-config section-name injection enables arbitrary config directives (core.sshCommand RCE)
CVE-2026-69097GHSA-3rp5-jjmw-4wv2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gitpython 3.1.53), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI gitpython
- Affected
- <= 3.1.52
- Fixed in
- 3.1.53
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3rp5-jjmw-4wv2 lists affected ranges: PyPI gitpython >=0 <3.1.53 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3rp5-jjmw-4wv2 lists affected ranges: PyPI gitpython >=0 <=3.1.52
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.0 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-69097: 0.27% estimated exploitation activity in the next 30 days; percentile 18.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In GitPython <= 3.1.52, the config writer neutralizes only CR, LF, and NUL in configuration names, but writes section names into the [...] header with no other escaping. A section/subsection name that contains ] [ " closes the intended header and opens a second same-line section, injecting an arbitrary config directive — with no newline required. Because a submodule name is attacker-controlled data (it comes from a repository's .gitmodules, or from an application that lets a user name a submodule) and is written verbatim into the parent repository's trusted .git/config, an attacker can set core.sshCommand (or alias., core.pager, core.fsmonitor) and achieve remote code execution on the victim's next git operation. Likely CWE-74 (Injection). This is a distinct variant of the injection addressed by GHSA-mv93-w799-cj2w / GHSA-v87r-6q3f-2j67: those fixed newline injection into config values/names (patched in 3.1.50); the [r\n\x00] guard added for them does not stop a same-line…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3rp5-jjmw-4wv2
- Revision 2 · amended ·
Amended from ghsa record GHSA-3rp5-jjmw-4wv2
- Revision 1 · created ·
Published from osv record GHSA-3rp5-jjmw-4wv2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-69097 Advisory: GitPython: git-config section-name injection enables arbitrary config directives (core.sshCommand RCE) IDs: CVE-2026-69097, GHSA-3rp5-jjmw-4wv2 Record: https://patchnext.com/advisories/cve-2026-69097 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gitpython 3.1.53. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI gitpython: affected <= 3.1.52; fixed in 3.1.53 ## Suggested inspection (read-only) - `python -m pip show gitpython`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gitpython. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3rp5-jjmw-4wv2 (OSV record GHSA-3rp5-jjmw-4wv2 lists affected ranges: PyPI gitpython >=0 <3.1.53 (fixed)) - Verified: https://github.com/advisories/GHSA-3rp5-jjmw-4wv2 (GitHub-reviewed advisory GHSA-3rp5-jjmw-4wv2 lists affected ranges: PyPI gitpython >=0 <=3.1.52) Commands are suggestions: review each one before running it.
Loading voting…