Skip to content

← Actionable
High, CVSS 8.1amended

Grav: Incomplete callable validation in blueprint dynamic fields allows arbitrary static method invocation and file disclosure

CVE-2026-69088GHSA-7pgq-cr25-xvc8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 2.0.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getgrav/grav

    Affected
    >= 2.0.7, < 2.0.11
    Fixed in
    2.0.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-69088: 0.29% estimated exploitation activity in the next 30 days; percentile 22.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Grav CMS's blueprint dynamic-field callable guard can be bypassed with a fully-qualified `Class::method` string, letting an account with only page-editing rights (`admin.pages`, not super-admin) plant a directive in a page's form-field frontmatter that invokes an arbitrary public static PHP method with attacker-controlled arguments. Using built-in gadget methods this yields, at minimum, arbitrary reading of any server-readable file (disclosed to anonymous visitors of the crafted page) and arbitrary creation/copying of files and directories under the web-server account.

Details `Blueprint::isSafeDynamicCall()` (`system/src/Grav/Common/Data/Blueprint.php`, method around line 488) is meant to block dangerous callables named in a blueprint's dynamic-field directives (`data-*@`). It only consults its dangerous-name denylist when the callable string does not contain `::`: ```php if (is_string($function) && !str_contains($function, '::') &&…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record GHSA-7pgq-cr25-xvc8

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-7pgq-cr25-xvc8

  3. Revision 2 · amended ·

    Amended from ghsa record GHSA-7pgq-cr25-xvc8

  4. Revision 1 · created ·

    Published from osv record GHSA-7pgq-cr25-xvc8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-69088

Advisory: Grav: Incomplete callable validation in blueprint dynamic fields allows arbitrary static method invocation and file disclosure
IDs: CVE-2026-69088, GHSA-7pgq-cr25-xvc8
Record: https://patchnext.com/advisories/cve-2026-69088 (revision 4, source checked 27 Oct 2026, 06:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 2.0.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getgrav/grav: affected >= 2.0.7, < 2.0.11; fixed in 2.0.11

## Suggested inspection (read-only)
- Packagist getgrav/grav: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getgrav/grav.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7pgq-cr25-xvc8 (OSV record GHSA-7pgq-cr25-xvc8 lists affected ranges: Packagist getgrav/grav >=2.0.7 <2.0.11 (fixed))
- Verified: https://github.com/advisories/GHSA-7pgq-cr25-xvc8 (GitHub-reviewed advisory GHSA-7pgq-cr25-xvc8 lists affected ranges: Packagist getgrav/grav >=2.0.7 <=2.0.10)

Commands are suggestions: review each one before running it.

Loading voting…