sentence-transformers local model loading bypasses trust_remote_code and executes custom Python
CVE-2026-68770GHSA-jhr6-gm9c-rqjv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sentence-transformers 5.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 5.6.0
- Fixed in
- 5.6.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jhr6-gm9c-rqjv lists affected ranges: PyPI sentence-transformers >=0 <5.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jhr6-gm9c-rqjv lists affected ranges: PyPI sentence-transformers >=0 <5.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-68770: 0.91% estimated exploitation activity in the next 30 days; percentile 60.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
sentence-transformers contains a security control bypass vulnerability that allows attackers to achieve arbitrary code execution by exploiting a logic flaw in the importmoduleclass helper within sentencetransformers/util/misc.py, where the guard condition includes an 'or os.path.exists(modelnameorpath)' clause that satisfies the trust gate whenever the supplied path exists on the local filesystem, regardless of the trustremotecode=False argument. Attackers who can control or influence the contents of a model directory on disk can place malicious Python files such as modeling.py referenced via modules.json, causing the code to execute at import time when an application loads the model with SentenceTransformer(path, trustremotecode=False), bypassing the documented security contract and achieving code execution within the loading process.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-jhr6-gm9c-rqjv
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-jhr6-gm9c-rqjv
- Revision 1 · created ·
Published from ghsa record GHSA-jhr6-gm9c-rqjv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-68770 Advisory: sentence-transformers local model loading bypasses trust_remote_code and executes custom Python IDs: CVE-2026-68770, GHSA-jhr6-gm9c-rqjv Record: https://patchnext.com/advisories/cve-2026-68770 (revision 4, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sentence-transformers 5.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sentence-transformers: affected < 5.6.0; fixed in 5.6.0 ## Suggested inspection (read-only) - `python -m pip show sentence-transformers`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sentence-transformers. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jhr6-gm9c-rqjv (GitHub-reviewed advisory GHSA-jhr6-gm9c-rqjv lists affected ranges: PyPI sentence-transformers >=0 <5.6.0) - Verified: https://osv.dev/vulnerability/GHSA-jhr6-gm9c-rqjv (OSV record GHSA-jhr6-gm9c-rqjv lists affected ranges: PyPI sentence-transformers >=0 <5.6.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…