Skip to content

← Actionable
Low, CVSS 3.3amended

ClickMigrate has Path Traversal in "revision -m" argument

CVE-2026-68549GHSA-vgf9-9mxx-hq54

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (clickmigrate 1.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact A path traversal vulnerability in the revision command allowed a crafted migration name supplied via the -m argument to escape the intended migrations directory. Under specific conditions, an attacker could cause the tool to create a .sql file in an arbitrary location writable by the user executing the command. This issue is only exploitable if an attacker can influence the migration name passed to the revision command, such as through an insecure automation or CI/CD pipeline that forwards untrusted input. Patches The vulnerability has been fixed in version 1.0.3 by validating and sanitizing the migration name to prevent directory traversal. Users should upgrade to version 1.0.3 or later. Workarounds Do not pass untrusted input to the revision -m argument. If upgrading is not immediately possible, ensure that only trusted users or automation can invoke the revision command and that migration names are validated before being passed to the tool. References - Fix commit:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vgf9-9mxx-hq54

  2. Revision 2 · amended ·

    Amended from osv record GHSA-vgf9-9mxx-hq54

  3. Revision 1 · created ·

    Published from ghsa record GHSA-vgf9-9mxx-hq54

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-68549

Advisory: ClickMigrate has Path Traversal in "revision -m" argument
IDs: CVE-2026-68549, GHSA-vgf9-9mxx-hq54
Record: https://patchnext.com/advisories/cve-2026-68549 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: clickmigrate 1.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI clickmigrate: affected < 1.0.3; fixed in 1.0.3

## Suggested inspection (read-only)
- `python -m pip show clickmigrate`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on clickmigrate.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vgf9-9mxx-hq54 (GitHub-reviewed advisory GHSA-vgf9-9mxx-hq54 lists affected ranges: PyPI clickmigrate >=0 <1.0.3)
- Verified: https://osv.dev/vulnerability/GHSA-vgf9-9mxx-hq54 (OSV record GHSA-vgf9-9mxx-hq54 lists affected ranges: PyPI clickmigrate >=0 <1.0.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…