Fulgur: Unbounded page slicing from attacker-controlled CSS height causes denial of service
CVE-2026-68523GHSA-j5cx-ph8g-95v3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fulgur 0.19.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io fulgur
- Affected
- < 0.19.0
- Fixed in
- 0.19.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j5cx-ph8g-95v3 lists affected ranges: crates.io fulgur >=0 <0.19.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j5cx-ph8g-95v3 lists affected ranges: crates.io fulgur >=0 <0.19.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-68523: 0.61% estimated exploitation activity in the next 30 days; percentile 49.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
fulgur converts untrusted HTML/CSS into PDF, commonly on a server that processes input supplied by many tenants. In versions prior to 0.19.0, a body-direct child whose CSS-resolved height greatly exceeds the page height was sliced into one fragment per page with no upper bound. The height is taken directly from attacker-controlled HTML/CSS (height, vh units), so a few bytes such as: forced on the order of 125,000 page fragments. The pagination code then allocates vec![Vec::new(); pagecount] and runs a per-page render loop, resulting in CPU and memory exhaustion. A non-finite height (one that resolves to +inf) additionally made the slicing loop's remaining -= lastsliceh decrement never terminate, causing an infinite loop. An attacker able to submit HTML/CSS to a fulgur-based conversion service can trigger this with a trivially small payload, denying service to the host and any co-tenants. Patches Fixed in 0.19.0. A MAXPAGES cap bounds the slice loop — halting it even for a +inf height…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-j5cx-ph8g-95v3
- Revision 1 · created ·
Published from osv record GHSA-j5cx-ph8g-95v3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-68523 Advisory: Fulgur: Unbounded page slicing from attacker-controlled CSS height causes denial of service IDs: CVE-2026-68523, GHSA-j5cx-ph8g-95v3 Record: https://patchnext.com/advisories/cve-2026-68523 (revision 2, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fulgur 0.19.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io fulgur: affected < 0.19.0; fixed in 0.19.0 ## Suggested inspection (read-only) - crates.io fulgur: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fulgur. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j5cx-ph8g-95v3 (OSV record GHSA-j5cx-ph8g-95v3 lists affected ranges: crates.io fulgur >=0 <0.19.0 (fixed)) - Verified: https://github.com/advisories/GHSA-j5cx-ph8g-95v3 (GitHub-reviewed advisory GHSA-j5cx-ph8g-95v3 lists affected ranges: crates.io fulgur >=0 <0.19.0) Commands are suggestions: review each one before running it.
Loading voting…