Glances: as_dict_secure() Value-Level Bypass Leaks Credentials in URL Values via /api/4/config
CVE-2026-68520GHSA-4h34-v6r8-mmjc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (glances 4.5.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI glances
- Affected
- < 4.5.6
- Fixed in
- 4.5.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4h34-v6r8-mmjc lists affected ranges: PyPI glances >=0 <4.5.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-68520: 0.40% estimated exploitation activity in the next 30 days; percentile 34.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Glances provides asdictsecure() explicitly designed for unauthenticated API access, with a docstring stating it returns "a sanitised copy of the configuration dict" where "Sensitive keys in remaining sections are replaced by ''". However, the implementation only checks KEY names against a regex pattern and never inspects VALUE content. The documented [ip] config section supports publicapi (URL), publicusername (login), and publicpassword (password). While publicpassword is correctly masked, both publicapi (when containing embedded credentials like https://user:pass@host/) and publicusername are returned in full to unauthenticated users via GET /api/4/config. Affected Versions Glances latest (Docker: nicolargo/glances:latest) Root Cause In glances/config.py, asdictsecure(): In glances/outputs/glancesrestfulapi.py: The [ip] config section documents: publicapi (URL), publicusername (login), publicpassword (password). - publicpassword → matches "password" → masked ✓ - publicapi →…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4h34-v6r8-mmjc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-68520 Advisory: Glances: as_dict_secure() Value-Level Bypass Leaks Credentials in URL Values via /api/4/config IDs: CVE-2026-68520, GHSA-4h34-v6r8-mmjc Record: https://patchnext.com/advisories/cve-2026-68520 (revision 1, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: glances 4.5.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI glances: affected < 4.5.6; fixed in 4.5.6 ## Suggested inspection (read-only) - `python -m pip show glances`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on glances. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4h34-v6r8-mmjc (GitHub-reviewed advisory GHSA-4h34-v6r8-mmjc lists affected ranges: PyPI glances >=0 <4.5.6) Commands are suggestions: review each one before running it.
Loading voting…