Skip to content

← Actionable
High, CVSS 7.1

Glances: --disable-config-exec does not cover on-alert action commands (incomplete fix of CVE-2026-53925)

CVE-2026-68519GHSA-59fj-m2j6-hcxh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (glances 4.5.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI glances

    Affected
    <= 4.5.5
    Fixed in
    4.5.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-68519: 0.18% estimated exploitation activity in the next 30 days; percentile 7.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In Glances 4.5.5 the --disable-config-exec flag was extended (GHSA-3vwc-qwhc-3mj7) to stop securepopen() from interpreting the shell operators &&, | and in AMP command values taken from the configuration file. The hardening was not applied to the on-alert action command path, which reads its command lines from the same configuration file. As a result, with --disable-config-exec enabled, a configured alert action that contains (file redirection), && (chaining) or | (pipe) still has those operators interpreted, allowing arbitrary file write / command chaining at the privilege of the glances process when the alert triggers. Affected code glances/actions.py (Glances 4.5.5, latest): By contrast the AMP modules were fixed: PoC (benign) glances.conf: Run glances --disable-config-exec and generate CPU load. When the cpu user alert reaches CRITICAL, /tmp/pocmarker is created — i.e. the operator was interpreted despite --disable-config-exec. The same in an [amp] command value is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-59fj-m2j6-hcxh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-68519

Advisory: Glances: `--disable-config-exec` does not cover on-alert action commands (incomplete fix of CVE-2026-53925)
IDs: CVE-2026-68519, GHSA-59fj-m2j6-hcxh
Record: https://patchnext.com/advisories/cve-2026-68519 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: glances 4.5.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI glances: affected <= 4.5.5; fixed in 4.5.6

## Suggested inspection (read-only)
- `python -m pip show glances`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on glances.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-59fj-m2j6-hcxh (GitHub-reviewed advisory GHSA-59fj-m2j6-hcxh lists affected ranges: PyPI glances >=0 <=4.5.5)

Commands are suggestions: review each one before running it.

Loading voting…