PHP_CodeSniffer gitblame report command injection via crafted filename
CVE-2026-67434GHSA-hmqg-cxww-wqhq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (squizlabs/php_codesniffer 4.0.2, 3.13.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist squizlabs/php_codesniffer
- Affected
- < 3.13.6>= 4.0.0, < 4.0.2
- Fixed in
- 4.0.2, 3.13.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hmqg-cxww-wqhq lists affected ranges: Packagist squizlabs/php_codesniffer >=0 =4.0.0 <4.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hmqg-cxww-wqhq lists affected ranges: Packagist squizlabs/php_codesniffer >=0 =4.0.0 <4.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-67434: 1.06% estimated exploitation activity in the next 30 days; percentile 64.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact PHPCodeSniffer versions before v3.13.6 and v4.0.2 contain a command injection vulnerability in the code creating the Gitblame, Hgblame and Svnblame report(s). As a result, running PHPCodeSniffer over untrusted files, for example, in a CI pipeline that scans pull requests, or on a developer machine reviewing third-party code, could result in attacker-controlled shell commands being executed when the Gitblame, Hgblame or Svnblame report(s) would process a file whose name contains shell metacharacters. Users using the default Full report, or any of the other non-blame reports, are not affected. Users on a runtime platform which does not allow filenames to contain shell metacharacters, such as " and ;, are not affected. Patched versions The issue has been fixed in PHPCodeSniffer v3.13.6 and v4.0.2. We recommend all users upgrade to these versions at their earliest convenience. Workaround Users of PHPCodeSniffer who cannot upgrade immediately should ensure they do not use the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hmqg-cxww-wqhq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-hmqg-cxww-wqhq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-67434 Advisory: PHP_CodeSniffer gitblame report command injection via crafted filename IDs: CVE-2026-67434, GHSA-hmqg-cxww-wqhq Record: https://patchnext.com/advisories/cve-2026-67434 (revision 3, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: squizlabs/php_codesniffer 4.0.2, 3.13.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist squizlabs/php_codesniffer: affected < 3.13.6; >= 4.0.0, < 4.0.2; fixed in 4.0.2, 3.13.6 ## Suggested inspection (read-only) - Packagist squizlabs/php_codesniffer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on squizlabs/php_codesniffer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hmqg-cxww-wqhq (OSV record GHSA-hmqg-cxww-wqhq lists affected ranges: Packagist squizlabs/php_codesniffer >=0 =4.0.0 <4.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-hmqg-cxww-wqhq (GitHub-reviewed advisory GHSA-hmqg-cxww-wqhq lists affected ranges: Packagist squizlabs/php_codesniffer >=0 =4.0.0 <4.0.2) Commands are suggestions: review each one before running it.
Loading voting…